Roon iPad App hangs or unstable after returning from background mode

Hello @Jack_Lee1

Welcome to the forum and thanks for reaching out!

Can I please ask that you reproduce this issue and let me know the exact local time + date it occurs at?

I’d like to see if the logs from your iPad contain further clues, and I can enable diagnostics mode for your account once I have the timestamp.

Thanks!

Hi,

It happened just now, at around 11:55am GMT+8. I was using the Roon app about 15 mins earlier and then stopped playback, put it into background. When I came back and click the app in the docker it crashed.

Please see if you can identify what happened. Thanks

Hi @Jack_Lee1,

Do you have another email that is registered to your Roon account?
I can’t seem to locate any Cores associated with the account from the email you’re posting from.
Can you please click my name -> message and let me know the email address you’re using on Roon?
Thanks!

Hi Noris,

I’m sorry for the confusion. The correct account is the current one posting this message. Thanks!

1 Like

Hi @Jack_Lee1/@Jack_Lee2,

Thanks for the info, I was able to locate the iPad under the @Jack_Lee2 account and I have enabled diagnostics mode for it.

Diagnostics mode automatically uploads a log-set from your iPad next time the Roon app is running on it.

Can I please ask that you open the Roon app on your iPad once more, use it for a few min and let me know here once you have done so? I can then check to see if the iPad report has been delivered.

A post was merged into an existing topic: Screen whiteout

Hi @noris,

I just did what you asked. Please see if the log was delivered.

Interestingly, the app didn’t crash this time, even after running in the background before restoring to foreground via the dock app icon. Perhaps enabling diagnostic mode cured the problem …

Hi @Jack_Lee1/@Jack_Lee2,

Thanks for letting me know, I can confirm that the iPad log was received.
I took a look through it and I’m not noticing any crashes on June 5th/11:55AM or the whereabouts.

I don’t believe diagnostics have any relation to the crashing behavior, all diagnostics mode does it upload a log set to our servers for analysis.

If the behavior occurs again, can you please record a short video of it?

Hi @noris,

Thanks for the confirmation. I’ll let you know in case it crashes again.

It won’t be possible to record the crash though, as by the time it happens the app will be gone so nothing to record.

Hi @Jack_Lee2,

You mentioned that the app typically crashes again once you restart it from the Dock:

Is it possible to record this behavior?

Hi @noris,

I’ll try to record it when it reoccurs. Since the log was enabled I haven’t yet encountered any issues. Even the trick of bring it to foreground via the dock works fine. Before that it was crashing 9 out of 10 times.

Well, I think the ios may also have updated during this time so not sure if that’s related. I’ll keep watching it and let you know in case the issue returns. Thanks!

1 Like

Hi @noris,

The app hangs just now (Around 3pm GMT+8). After a few retries it seems to have restarted itself and resume working. I stopped the app a few minutes afterwards so please see if a log was submitted. Thanks.

1 Like

A post was split to a new topic: Roon iPad App Hangs

Hi @Jack_Lee2,

Thanks for letting me know the timestamp. It looks like the previous log request timed out so I have submitted another request. No need to reproduce the issue, but please open the Roon app when you have a chance and let me know so I can check if the logs are delivered this time around.

@noris,

Sorry for the late reply. I have used the app again. Please see if the log was delivered. Thanks.

1 Like

Hi @Jack_Lee2,

Thanks for the ping, I can confirm that the logs have been delivered, although unfortunately it doesn’t look like there is much information in them regarding the issue.

We recently released a new build of Roon this week, can you confirm if the new build also displays the same behavior as before?

@noris,

The issue has not occurred since enabling the log (or whatever happened). I’ll let you know once it re-occur. Thanks.

Hi @noris,

Okay, it just re-occurred. When switching back to the app via the Dock, the app’s screen is all white. I then selected Albums and no album was displayed, instead it says “Try removing focus filter” or something like that.

I then clicked on the Focus icon and it crashed. Hope the log was delivered so that you can look into it.

Thanks!

@noris,

Btw, the app ver is 1.7 (Build 571).
ROCK is ver 1.7 (build 555)

Hi @Jack_Lee2,

Thanks for letting me know the timestamp. I don’t see the logs delivered yet, but I’ll re-activate diagnostics mode for your iPad.

Last time I took a look at logs, they weren’t very helpful though, so I was hoping you could submit a recording of how to get into this state from when Roon is working properly at the start?

Being able to reproduce this behavior at-will in a QA environment would be the most helpful way to address this issue.