Roon is dropping playback on grouped Bluesound devices

Roon Core Device

Nucleus with no hard drive, running 911 build.

Networking Gear & Setup Details

Orbi WiFi 6 Router AX4200 with two satellites, running from Starry Internet,

Connected Audio Devices

Bluesound Vault 2i, Two Bluesound Pulse Flexes 2i and two Bluesound Pulse Minis

Number of Tracks in Library

2134 tracks (not done ripping CDs, lol)

Description of Issue

Hello all–
I am still experiencing tracks skipping on Tidal and also on my Bluesound vault 2.

I have set my DNS to Google and also the other one recommended (Cloudflare) as second choice and upgraded the Nucleus to latest build. The problem has actually gotten worse.

Internet speeds are consistently strong at 200.

What happens (from Tidal at least) is that Roon will play 2-3 songs, then start the next. That song will play a bit and then suddenly sound will stop playing from the 2 minis first, then stop from the Fiexes, then music stops completely, then it goes to next track. This happens over and over again and is most distressing.

The only thing I can think of is that my primary control (iPad) was running the old build and so that caused this to continue? I am glad to say the new build was downloaded to the iPad today, so will try out this evening.

I must say that I haven’t had the Nucleus for 30 days yet and am so frustrated that if it doesn’t work tonight, I am seriously considering send back for refund.

Roon worked great for quite a while living on a MacBook Air, but that stopped in late 2021 or early 2022. My family listens to music to relax, and Roon has caused nothing but stress for 8 or so weeks, so I am starting to think the product isn’t for us. I am also disappointed that support is so poor. I wrote the support folks on Jan 5 and have gotten one reply on Jan. 13. Nothing since. Most odd, nothing even after the purchase of their hardware. Having formerly been in the software industry i find that troubling and am asking is this worth the hassle when the company provides so little support? While I mostly want to fix this issue because I LOVED Roon, this whole experience has shaken my belief in the software.

(Just noticed an FAQ that says to always open support queries here, so that may explain why email support has been slow).


Hi Michael,

Roon support is active on the forums and I’m sure they will be by soon to discuss.

In the meantime, are all your blue sound devices grouped? I ask because in a group, one device having issues can cause them all to stop. So, I would concentrate on just using 1 endpoint not in a group and see if it has stable playback.

Thanks Daniel. That’s a great idea. We will try out this eve.

The latest update has actually made the skipping of tracks worse. It’s so frustrating. We just spent the $ to buy a Nucleus because it’s supposed to improve the experience. EVERYTHING is worse. And the customer support is a joke. They sell a $1500+ product and don’t respond to emails. This is a disaster. We are done. Sending it back and canceling subscription. I’d rather deal with Bluesound’s terrible interface and subpar sound then deal with the rage I feel as track and after track stops playing and skips to the next. Just done. Roon is a terrible business.

I first contacted support on Jan 5, and have received precisely one reply (Jan 13), despite having written back with updates and questions many times since then… Therefore, I am not inclined to open a support thread here since support—even for folks spending $1500+ for their hardware—doesn’t seem to exist. When I pay for someone’s hardware, I expect support.

Does your experience differ? Because I can type “Roon doesn’t work” into Google and see an awful lot of folks having problems over many years.

What I am puzzled about is that it did work for us, for maybe over a year. But basically hasn’t in 2022. So that’s the reason I am frustrated and wondering if I am the only one still having problems.

No, it is also slow or non existing over here.


And since previous update I have also issues being reported but no reaction at all.

Hello @Michael_Coventry,

Sorry for the lapsed response from me in our ticket system. From some of your responses there I was under the impression that your TIDAL skipping had been cured with DNS changes. I apologize for misunderstanding.

What you’re describing here is commonly a symptom of network difficulties. So let’s try to peel back to looking at that first.

Take a few moments to look over this guide on Networking. Toward the bottom of the article you’ll see some setting recommendations specific to your Orbi router. Please make sure that your router settings match our recommendations and look to see if ipV6 is activated on the router. If so turn that off:

Additionally, please adjust your DNS settings so that Google is primary and secondary. ( & (

Another question: how is your vault library connected to internet? Wired or wi-fi? If wi-fi tried a wired connection.

Lastly, as @Rugby encouraged - start playing back to a single endpoint as a test. If playback is steady then add an additional endpoint until you encounter a stoppage or skip.

Please let us know how things progress. We’ll watch for your reply.

1 Like

Thanks, all. I am glad to learn better protocol for getting support. And sorry for any confusion Jamie.

We’ve made all the changes indicated and will be testing over the next couple of days. We’ve played it for a bit today and it’s been purring along, so hopefully that will be true at night as well.

1 Like


While it played smoothly for a couple of hours this afternoon, tonight it played for about 40 minutes, then a song stopped playing to the bluesound minis (in front of room) then played a second or two longer on the two flexes then skipped to next song.

To test the simple to complex method I would just play to one speaker and see what happens and then slowly add speakers? Is that what that means?

BTW both Roon and Vault are wired into the Orbi. Should I try them wired into Starry? I did Orbi because that’s the source of my WiFi network.

Thanks for any help.

Hello all

One thing I am observing is that some Bluesound speakers connect at 2.5 and others at 5 ghtz. Could that be a problem? I know I’ve tried to force things to connect to Orbi at 5 in the past and had issues because it likes to decide.

Also, even just playing to one speaker, no skipping but some stopping.

When I added second speaker it started skipping. Both are connecting at 2.4 hertz.

Moved back to one speaker. Skipping problem recurs. What is the test here? Do I hardwire one speaker?

Hey Michael,

I’m so sorry about the problems you are experiencing now. we will look into your logs try to find some clues here, could you please try to hardwire one end point to see if that can improve things?


Hi @Michael_Coventry,

Thank you for your patience here while we reviewed logs. What we’re seeing is that an abundance of network problems and slow loading media is causing your stream to drop. It looks like you were enjoying some Madeleine Peyroux on about six devices when the stream dropped last evening.

We have two possibilities here

A. The network falls down after adding x number of devices.
B. Grouped playback breaks when adding a specific device that has poor network connectivity.

Let’s try to figure out where the problem lies by doing the following:

  • (First grab a pen and paper to keep notes on the order you use when adding the devices)
  • Play the same Madeleine Peyroux selection to a single Bluesound endpoint
  • Let music play for at least two minutes to ensure that the stream is stable
  • Add another Bluesound device to the group,
  • Wait at least two minutes, then repeat
  • Continue to do this and allow the stream to stabilize each time
  • When you encounter a drop, note the unit that was added that caused the behavior.
  • Restart your Core, Router, and Bluesound devices.
  • Repeat the above in the exact order you used for the first test and see if the drop occurs again.

Let us know how many devices you were able to group successfully before the stream dropped and tell us how the device that caused the drop is connected to internet.

We’ll be watching for your reply and get back to you as quickly as possible.


Thank you for checking the logs.

So, we only have four speakers we were using so it’s potentially problematic that it shows we were playing to six devices? We have two Sonos in the office but they are a different group.

I was doing a version of what you describe and it was skipping with just one speaker. But we will try doing this with exactly the steps that you outline.

Does the fact that some speakers connect at 2.4 and others have 5 matter?

It can depending on signal strength and environmental issues. The best test is to eliminate wifi totally and connect the one test unit via Ethernet, which is what I think Jamie was suggesting.

Apologies Michael, my saying six was prompted by my interpretation of your Zone descriptions (Window +, Dining Room +, etc)

Thanks! I just wanted to make sure there wasn’t some phantom connection to something. LOL.

I think we’ll try the testing of one unit via Ethernet first, then move on to the wifi testing protocol you suggest.




So I am pretty sure the problem starts when I add my little Flex speakers. I played it for quite a while with one of my larger pulses wired in and the other on wifi and no skipping. Earlier I had built up more quickly (play two minutes, add another, and so on) and it played 45 minutes then skipped.

Question is, how do I proceed? What can folks suggest I do to make the flexes work? I will see if I can update their firmware, but other thoughts welcome.

Although it is about connectivity maybe see if this is set, from the Roon network faq

Netgear Orbi Routers

If you’re making use of an Orbi router, we recommend unchecking Disable IGMP Proxying in your router’s settings. This setting can interfere with the ability for Roon Remotes to connect to the Roon Core.

Thank you for the idea. Yes, I have made sure that is unchecked on the Router and the Orbi.

1 Like