Roon keeps locking up on Windows 11

I brought this topic up before, and when we solved the screen resolution problem, I thought the lockup problem was solved too. It wasn’t, despite a couple of Roon updates since then.

I do hope this can be fixed someday. It seems to be happening whenever Roon is running in the background for more than half an hour or so.

The system details are in the original post.

Hi John,

As a workaround, have you tried setting up a secondary desktop, running Roon on that not minimized. That way if you need to access Roon you switch desktops, and, since Roon is not in the background it hopefully doesn’t lock up.

Cheers,
Daniel

Good idea. Trying it now. My experience is that Roon locks up whether it is minimized or in the background, but this might work.

Hey @John_Gallup,

I wanted to check in on this thread to see if @Rugby’s note was helpful?

I’ll be monitoring this thread for your reply :+1:

Second desktop works better, but Roon still hangs on it sometimes. It’s an odd problem. Thank you for checking.

Hey @John_Gallup,

Thanks for letting me know, and I’m sorry to hear you’re still running into hanging issues. If possible, please take note of the date and time the next time it happens, as well as the specific roon remote device you are using, and share that info here.

We’ll enable diagnostics on your account to investigate what might be going on at the time of the hang :+1:

Will do. Thanks for your continued attention to this problem.

Roon locked up today (13 Nov 22) at 3:40 pm Pacific Standard Time (US).

Source: Roon ROCK on an Intel NUC
End point: dCS Bartok streaming DAC
Locked up device: Dell XPS 13

NUC and Bartok connected via Ethernet, Dell via wifi

When I went back to Roon on the Dell, the program screen came up, but when I tried to pause the play, nothing happened. In a few seconds Roon crashed. Roon was not playing on a separate desktop.

This is similar to the behavior I have seen since first addressing this issue here.

Hey @John_Gallup,

Thanks for the information! It looks like Roon hit a few server errors over the weekend that coincide with the time of your PC remote crashing. After reviewing diagnostics, it does look like a few websocket exceptions had been thrown, causing your system to lock up and crash.

Followed by that, it looks like there may have been some change in network reachability for the PC. How is this PC connected to your core? If possible, would you be able to test hardwiring it to your core or your router?

It may be worth giving your network a hard reboot as well to get everything back on a clean slate.

Let me know :+1: