Roon for Windows 11 keeps locking up

Roon Core Machine

Dell XPS-13 on wifi

Networking Gear & Setup Details

Ethernet from Roon ROCK on an Intel NUC to a dCS Bartok DAC.

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Listening along just fine, but when I go back to Roon on the computer listed above, which is where I selected the music I’m listening to, Roon comes up but doesn’t respond to any clicks. Sometimes it does come back; sometimes I get impatient and crash it with Task Manager. It didn’t used to do this.

I’ve noticed the same thing in Windows 11. It freezes often. Usually comes back for me but sometimes I also have to end the task and start again. I’m on a Lenovo X1 with a wired ethernet connection through a TB4 dock to a Roon ROCK on an Intel NUC (also wired).

1 Like

Hi @John_Gallup and @paul_s_45 both.

I have been collecting information on this issue and similar. Can you both reply with your video card configuration on these machines? We would greatly appreciate this assistance in tracking your issue.

Thanks,
Wes

1 Like

Intel UHD Graphics 620

Intel Iris Xe Graphics (came with Dell XPS 13 purchased March 2022). Laptop is connected to network via wifi; Roon Rock and other output devices are Ethernet.

@John_Gallup. @paul_s_45,

Thank you. We are tracking instances of freezing and appreciate the information.

Wes

Is a fix coming soon?

Any progress on this? Roon is still locking up and/or crashing at least once a day.

Hi @John_Gallup,

This is something that is affecting very few users but as you know, is mission critical to the Roon experience. We will have a fix coming soon. While there is no exact date, developers have been looking at all possible angles for a resolution and it was discussed today so it’s something we’re actively working on.

Thank you for your continued patience.

Regards,
Wes

1 Like

I should probably have mentioned that I have to start Roon with this string:

C:\Users\JohnG\AppData\Local\Roon\Application\Roon.exe -scalefactor=1.25

You’re welcome, John. I hope we get it sooner rather than later. Feel free to check back at your leisure for updates.

Wes

Was hoping Roon 2.0, which I just installed, would fix this problem. Alas, it did not.

Hi John. I’m so very sorry to hear this. Can you please give me an instance date/time to go on for my diagnostics? I will bring this up in my next meeting with development and see what we can do to get you back up and running smoothly.

Wes

Hi Wes,

As I say, it’s not a big problem, just a nuisance. Anyway, it happened this morning after I’d been listening for an hour or so. I clicked on the Roon icon on my taskbar, which made Roon the foreground application. I clicked on the “Pause” button at the bottom center of the Roon screen, and nothing happened. To actually stop the play I had to crash out of Roon and start it again.

This doesn’t happen with my Android phone Roon app. It seems to happen whenever Roon has been running in the background on the Windows 11/Dell XPS 9305 combination. I don’t think it happened with Windows 10. I should also note that to allow Roon to run full-screen on this computer, I must use this string to start the program:

C:\Users\JohnG\AppData\Local\Roon\Application\Roon.exe -scalefactor=1.25

Otherwise no problems, and Roon ARC went to work flawlessly (on the phone; haven’t tried it on the computer yet). If you need other details let me know.

Thanks for you continuing attention

Regards,
John Gallup

Have you tried omitting the custom string?

One of the things we have seen here is that Windows crashes have been tied to the file that manages the last known windows position.

Wes

Hmmm…starting Roon without the string gives this:

Does this change at all when changing between resolutions on the XPS?

Let’s try this. Close Roon. Navigate to the C:\Users(username)\AppData\Local\Roon\Database\Registry\Client folder. Find the saved_window_pos file and add a .old to the end of it. Reopen Roon and see what happens. I’ve just tested this and Roon rebuilt the file in question.

Wes

1 Like

That did it! Thank you!

1 Like

I’m so happy to hear that! Enjoy the music, friend.

Wes

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.