Roon keeps losing connection to ROCK NUC

The problem remains. I disconnected the USB drive, turned off Background Audio Analysis Speed and On-Demand Audio Analysis Speed, and reconnected the drive. The drive appeared in storage settings, then Roon briefly displayed the tracks in the “Tracks” screen, then the connection was lost and the same cycle started again. 5:34, US Mountain Time.

Following this topic as I’ve recently experienced similar issues with my NUC core.

Welcome to the community, Tyler! I’m sorry your introduction was under such frustrating circumstances. Is Roon totally shut down for you, or does this happen only occasionally?

I tried disconnecting the USB drive and pointing ROCK to my NAS drive. That worked, to some extent. I can look at my library, and play tracks, and the connection to the Core remains stable, but it didn’t keep my “Favorites” data. The past Queue is there, but all the tracks are marked “Unavailable.” sigh

Hi @Antonio_Bendezu,

Thanks for giving that a try. I’ve enabled diagnostics on your account so the team can take a look at this instance of the crash. We appreciate your patience here while we continue to look into this.

Update: I left ROCK as I described above (looking to my NAS’s music folder); I closed the Roon install on my desktop that I was using as a remote; after a few hours, I opened Roon on my desktop again, and it is doing the same thing it was doing when ROCK was pointed at the USB drive. To be clear, the USB drive has been disconnected that whole time.

This HAS to be a problem with ROCK or the NUC, no?

Thanks Antonio! Roon has been great up until recently. It drops out only occasionally. Most often in the evening. It acts like it’s an internet (NUC loses connection with Tidal) or WiFi (phone can’t connect to the NUC) issue, but we can stream Netflix in 4K right before or after with no issues, soo…:man_shrugging:

@dylan: do you have any progress to report? We’re up against the weekend, and I’m getting more and more bummed at the idea of a weekend with no music. Thanks much.

Hi @Antonio_Bendezu,

I met with the team to discuss our next steps here today. Upon their review of the latest diagnostics report, they’re seeing signs that Roon is trying to extract data from media and is failing to do so, and resulting in a crash. The report isn’t clear on exactly which media is causing this issue, so we were hoping you could move and media that was added to the Roon watched folders in the last month out of the folders. After doing so does the crash persist?

Alright. I disconnected my NAS, so I could get at the Roon settings. Then I verified that I could access the ROCK Core via IP address (yes). Then I rebooted the NUC. Then I reconnected the USB drive. Then I went to the storage settings, and ROCK “imported” all the tracks immediately, and it started “scanning” them (very quickly). While it “scanned,” I could filter all tracks to see my favorites, and I was able to shuffle play from the All Tracks list. It even played for a few minutes after the storage settings were done scanning. Then, abruptly, it stopped playing, and the problematic behavior started again.

So I closed the Roon remote I was using (on my desktop), and I navigated to the USB drive via Windows Explorer, and I deleted all content that was added since June 27, 2019. I restarted the Roon remote on my desktop, and the behavior started again. It would show my tracks (I left it at the All Tracks window last time it was connected to the ROCK Core) for a few seconds, then I got the Lost Connection window, then to the dynamic Roon symbol, then back the All Tracks window for a few seconds, and the cycle continues. 7:25 pm Mountain Time.

So… I think the team might have it wrong about extracting data from the media, no? Isn’t the problem more with the connection between the Remote and the ROCK? 10 days of diagnosis, and you guys just had me delete files older than the last round of deletions.

I’m beginning to lose confidence in the team’s ability to properly diagnose this problem, especially, since it takes several days for y’all to suggest a bigger version of a previous failed suggestion. Is it possible to start over? The only library data that I really care about is my Favorites list. Is it possible to extract that list from the backup files? If I could get that list, I could try installing the Core on fresh hardware and manually designate my favorites (or if there is a more automated way to do that from the extracted list, then I’d prefer that).

I hope this support ticket has crushed the open-time record for you guys.

Hi @Antonio_Bendezu,

The team has been investigating your report and I wanted to follow up with the current status.

Our team is continuing to work on this, but we believe that if you start with a fresh database, you will be able to use Roon. Please see the following instructions for starting a new database:

  • Create a Backup of your current Roon Database
  • Stop RoonServer from running in ROCK’s WebUI
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the Roon App to generate a new Roon folder

Let all of your media re-import and let us know if you see the same behavior. Please keep the RoonServer_Old folder as we will need this to restore the database once our investigation is concluded.

Following your instructions right now. Had to disconnect the USB drive to get to the Settings menu. When I went to stop RoonServer at the WebUI, it tried to stop, but then it gave me a message that it couldn’t stop it, and it suggested that I reboot. I rebooted, and it was able to stop RoonServer after the reboot.

I’ll report again after it finishes importing. Thanks much.

The new instance of RoonServer imported all tracks just fine. I also re-added the tracks that I had deleted as part of the diagnostic process here. Roon is working fine. There is one difference: while using the previous instance of RoonServer, it would take Roon a few seconds (20-30) to play a track if I had not played anything in a few hours. I assumed that the delay was attributable to the USB drive having to spin up. However, the new instance of RoonServer is not suffering from that delay. Tracks play immediately.

If you guys know how to recover my favorites and import them into the new instance of RoonServer, I would consider this ticket resolved on my end.

Hi @Antonio_Bendezu,

In order to recover your playlists and favorites, you’ll need to use the old database which can be recovered by restoring a backup or by renaming the RoonServer_Old folder back to RoonServer when Roon is not running (please note that you’ll need to change the current RoonServer folder to something else, like RoonServer_New).

Before doing this, can you confirm if you have the album Pale by Toad the Wet Sprocket in your library? We’ve traced similar reports of crashing to this album. If you do have this album, try removing it from your Roon watched folder and then switch back to your old Roon database. After doing so does that database work for you?

I did have the Pale album. I deleted it, but that did not fix the problem. I’ve had that album in my library since July of 2017, so it seems unlikely to be the cause of the problem (unless a recent Roon update made it a problem, I suppose).

Hi @Antonio_Bendezu

Thanks for confirming that, and for your ongoing patience here. The team has received a database that is exhibiting similar issues from another customer and is currently investigating this further. As soon as they have more info I’ll be sure to reach out.


Hi @Antonio_Bendezu,

It seems as though there may be more than one album by Toad The Wet Sprocket that seems to be causing issues. Another user experiencing the same issue removed all albums by this artist and things are now working for them. If you have any other albums by this artist can you give it a try and let us know if it changes anything?


Removed all albums by Toad The Wet Sprocket. It failed in the same way: Roon Remote connected to the RoonServer, and I could navigate and play tracks while the software scanned the tracks (about 30 seconds); once scanning was finished the connection to the server was lost, and the cycle started over again.

A post was split to a new topic: NUC running ROCK crashing / losing connection

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.