Roon Library suddenly stopped auto updating

Core Machine (Operating system/System info/Roon build number)

Synology DS415+ (INTEL Atom C2538, 8192 MB RAM). Roon Server installed on an SSD disk, while the music library is installed on an HDD volume.

DSM version: DSM 6.2.3-25426 Update 2
Roon version: Roon 1.7 (Build 667)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Gigabit Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Sonos Play:1, Play:3, Apple Homepod

Description Of Issue

About a month ago Roon suddenly stopped auto-updating the library.

The only way to trigger an update is to restart the Roon server or disable and reenable the music folders from the Roon Settings -> Storage page.

Based on additional research of similar issues within the forum, I also tried modifying the maximum numbers of inotify handles (https://forum.syncthing.net/t/setting-inotify-limit-permanently-on-synology-diskstation/12221) but it didn’t solve the problem.

A post was split to a new topic: Roon Library stopped auto updating

Hello @Nikos_Katagas, and welcome to the community! If you force a rescan of your watched folder does it work? Also, can you share a screenshot of Settings>Storage?

Hello @nuwriy, thank you for reaching out. Yes, forcing a rescan also works. It’s only the automatic process that has stopped working. If I force a rescan, disable and reenable the folder or restart the server, Roon Library always imports the new files.

I’m attaching the screenshot of my storage settings page, as per your request.

A post was split to a new topic: Roon library stopped auto updating (QNAP)

Hi @Nikos_Katagas,

Typically Roon’s ability to auto-update when new music is added is dependent on the NAS’ ability to properly notify Roon that there was a change made. We’ve seen a couple reports recently that this hasn’t been working as expected, though, and we are looking into why that might be. We’ll be in touch once we have more information.

Thanks for the report!