Roon losing my audio devices

Core Machine (Operating system/System info/Roon build number)
Mac Mini.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
MK HiFace 2 to REGA DAC.

Description Of Issue
For last week my computer and iPhone app keeps losing track of my audio devices. Very frustrating. Earlier this afternoon this happened twice. Then everything worked. Then at 6:15 tonight it happened again. I go to access and play music and it shows all my music que etc but says I have no audio devices. This happens both on computer and on app. If I fiddle for awhile it then resumes proper play. Please tell me how to fix

Hi @Joe_Bornstein,

Have you made sure to add Roon/RAATServer as exceptions to your Mac Firewall? You can use these instructions from Apple to check this aspect.

I would also check for any other Antivirus/Firewall applications which could be blocking Roon from working properly, in the past I have seen reports surrounding McAFee/Bullguard/Little Snitch, Kaspersky, so if you use any of these I would make sure the correct exceptions are in place.

I checked and I do not have any firewalls active for my Mac Mini. Also no anti virus etc. Other solutions please.

Hi @Joe_Bornstein,

Can you please share a screenshot of what your Roon Settings -> Audio tab looks like when this issue occurs?

What exactly do you do to get out of this state? Can you be a bit more specific?

By fiddling I mean I scroll through my music. Also go to audio settings which when this is happening shows no Audio devices.

Add imag

Add images

es

Hi @Joe_Bornstein,

It appears that the screenshot you uploaded didn’t go through properly, can you please try to re-upload it using the image upload button?
Image%20Upload

What is your network setup like, can you list the model/manufacturer of your networking gear including router, switches, access points, ect?

The shot just shows at the bottom of the screen the words “Manage Audio”

hi @Joe_Bornstein,

If you click on the “Manage Audio Devices”, are any devices listed there?

Can you please provide your network setup info in case we need to investigate this aspect? Are you using any VPNs in your setup?

My Mac Mini (late 2012) is wired thru MK Hi Face 2 USB DAC to a REGA DAC (which can accept 24:192 files) then connected to Cyrus bi-amped system and then Royd Speakers. The Mac Mini is connected through wifi to my Bell 3000 network. It uses the wifi to stream music to 2 separate SONOs One speakers which are in different rooms. When Roon stops working and cannot find audio devices it fails to recognize the Stereo hard wired system and the SONOs at same time.I am not using any VPNs. When Roon stops working I can still connect with the Mac Mini wirelessly. Here are a few screenshots that show setup.

Hi @Joe_Bornstein,

Thanks for the additional info.

Is there any change in behavior if you temporarily connect your Macbook via Ethernet instead of having it connected over WiFi?

I noticed in this screenshot that you have LogMeIn Remote Sound. When this issue next occurs, can you try quitting out of LogMeIn and verify if that changes the behavior at all ?

Sure, but I don’t have logmein active and never use it

Just got home and Roon down again.

Add images

![image|230x500](upload://xdUAIlOaNh7iW3audB7RrQhbJBk.jpeg)

So on my iPhone I got manage audio tab again. Then I went to my computer and on that screen saw same message, but then 20 seconds later it went back to normal? Lomein not running

I am also having a separate Roon issue and wonder if there could be any linkage? When I look at lists of albums or artists half of them don’t display the album artwork - just grey stuff. But when I click on the album or artist the small versions of albums usually do display the artwork. So it is there but not reliably displayed. I am attaching to screen shots to show what I mean. Look at Duke Elington

Hi @Joe_Bornstein,

No, I don’t believe this is related. The Grey stuff you see there is just a generic artist photo when we don’t have actual artist photos to display. After you clicked on Duke, you’re seeing an album cover, which is different than the artist pic.

As for the main issue, I wonder if there is any change in behavior if you try to reinstall Roon, can you use these instructions to do so?

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder

How do I * Restart/Reinstall the Roon App to generate a new Roon folder

Either:

Restart the app on the PC by clicking on the Roon Icon to start the program.

Reinstall Roon by running the Installation program again that you downloaded.

1 Like

Hi @Joe_Bornstein,

On Windows clicking the Roon shortcut automatically generates a new database but for Mac you might have to reinstall Roon from our downloads page. Please do give this a try when you have a chance, thanks!

Will I have to provide my subscription or membership number/ID? IF so where do I find that?