Roon Losing Sync on Track Changes

Core Machine (Operating system/System info/Roon build number)

Windows 10, latest - problem has been going on for over a year with multiple versions of Windows 10 and Roon.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet. Not the problem, it’s a USB thing.

Description Of Issue

This is a persistent problem I’ve been having for over a year - more usage recently has made it very annoying.

Equipment:
- PC with Roon, storage (custom built)
- Benchmark DAC3 HGC
- (later experimenting) Rpi3 with Ropieee acting as a Roon bridge
- (also later) USB powered hub

Problem:

Roon periodically loses sync with the DAC. The DAC USB light starts blinking and it disappears from Windows. Roon is generally continuing to play as though nothing happened.

Unplugging and replugging the DAC’s USB connection is neccessary. This does not always solve the problem. Pushing play again often immediately loses sync (and playing continues in the app), and I must repeat.

Adding a powered USB hub may have lessened the problem a small amount, but not much. Switching to using the Ropieee as a network bridge did seem to reduce the frequency of the problem, but not eliminate it.

I’ve talked with Benchmark tech support at length, and the DAC appears to be working fine. I’ve never been able to reproduce the problem with VLC or Windows Media Player.

Lastly, this problem only appears when tracks change, and seems to be worse when a sample rate change is involved.

Thanks,

Shayne

@support just bumping this ticket. Thanks!

Hi @Shayne_Hodge

Does this problem occur with any other endpoints or just the Benchmark DAC?

Are you using any DSP with this DAC? If so, does disabling it result in any change?

The next time this happens can you let us know the time it occurs and the track you see if happen with, and then use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service)? Thanks!

The DAC is the only endpoint I have. All DSP is off. Cable has been changed out. I will upload logs later tonight.

Sorry for the delay, this took a while to reproduce. The Beatles in Mono box set was playing You Know My Name, then Roon Radio kicked over to Rag Mama Rag on Tidal, and my manually selecting Teddy Thompson / Shine So Bright (local) caused sync to lose though it still showed as playing. Note that going local to streaming or vice versa is not neccessary for this to occur, nor is using Roon Radio - it can happen all local picked by me.

I disconnect and reconnected the DAC and restarted the song and it worked. (It doesn’t always. Has taken 5+ reconnect and reattempts in the past).

Logs: Dropbox - Logs-shayne-hodge.zip - Simplify your life

I’m seeing the events in the log file without a number suffix, 4/6 at around 10:04 - 05

Thanks,

Shayne

1 Like

I’ve had this happen about ~10 times since uploading those logs, including once or twice where I had the unplug and replug more than once.

@dylan just checking to see if anyone has had a chance to look at this. Thanks.

@support just bumping this as it’s a persistent problem.

Hey @Shayne_Hodge,

I am very sorry for the delay in getting back to you. I can only thank you for following up on your initial post.

Unfortunately, Dylan had to take off the entire week last week as he wasn’t feeling well. Now that the weekend has passed, you should hear back from him on this thread.

Please, sit tight :pray:

Bumping this again, it’s still a persistent problem, and it’s one I’ve already been over with Benchmark tech support and they can’t find anything wrong. While it happens on both Roon from a PC and Roon on a Rpi with RoPiee, I’ve never had this problem with WMP or VLC.

Hello @Shayne_Hodge ,

Thank you for sending those logs over and for your patience here while we’ve had a chance to review them.

Looking over the log, it looks like your local System Output zone is also losing sync to Roon and there are quite a few Network Errors in the log as well.

Just to confirm here, when this issue occurs, you are playing to the Benchmark DAC3 as an individual zone and not in a group, correct? Does System Output work for you reliably 100% of the time?

Have you tried to perform a clean reinstall of Roon yet? This could be a good troubleshooting step, just to ensure that everything is in a fresh state:

  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if issue persists on fresh database before restoring the backup (on DAC3 and on System Output zones)

Thanks!

Are the network errors to the internet or local network? The former is unsurprising, the latter would be very surprising - though it would affect DAC sync?

I’ve done a reinstall without the new db and the problem persists, let me try with removing the db.

I have no groups setup. I’ve also never used system output; this is a headless PC with the Benchmark being the only way out other than the MB audio which has nothing hooked up.

Thanks,

I’ve removed Roon and RoonServer and reinstalled and built a fresh library. I also updated any outdated motherboard drivers (LAN, etc).

Triggered the same problem again this morning - logs @ Dropbox - hodge-may-logs.zip - Simplify your life , check about 1030AM today.

Also continued testing with VLC and can’t replicate the problem with it.

Thanks,

Shayne

Hi @Shayne_Hodge ,

Thank you for sending the logs over and for your patience here while we’ve had a chance to review them.

Looking over the log, there doesn’t appear to be any playback successfully happening to the Benchmark as far as we can tell, but System Output is working as expected.

Have you by any chance updated to the latest Benchmark firmware and driver?

If the firmware is up-to-date, do you by any chance have another PC running you can try to connect the Benchmark to see if this issue impacts multiple PCs (I realize that you have tested a Rasberry Pi, but another standard Mac/Windows PC would give us more clues here.)

Thanks!

I’ve talked with Benchmark extensively, and they’ve verified the firmware is current and no driver is necessary.

I can try a laptop and see. Does the RPi have logs I can pull?

Reproduced the problem on the laptop, on the Boccherini. Will now work to see if I can reproduce with WMC or VLC.

I ran VLC on a looped playlist for 48 hours and couldn’t reproduce the problem with it. I’ll also try with WMC.

What you describe here sound a lot like my problem, but for me it’s HQPlayer that gets totally bricked. Restarting HQPlayer is the only solution. I will create a separate ticket, but just FYI.