Roon lost control of audio device message - KEF LS50w

Core Machine (Operating system/System info/Roon build number)

ASUS Desktop/Windows 10 Home/ Intel Core i7-6700 CPU @ 3.40GHz/ 64-bit operating system/232Gb SSD Drive & 2Tb hard drive. Roon installed on SSD drive.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Telstra branded Sagemcon F@st 5355 WiFi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

KEF LS50W speakers Wifi

Description Of Issue

@support Roon appears to up and going but nothing happens and after 30 seconds to a minute a message briefly appears saying ‘Roon lost control of the audio device’. I did manage to get Roon to play for up to 6 seconds the first couple of times I tried before it stopped and the message eventually appeared. Since then no music at all. The speakers work just fine via their own app.

Hi @Bruce_Spencer,

Apologies for the delay in getting back to you here. Can you please confirm if the behavior is the same if you plug in both the Core and the LS50s via Ethernet to the primary router?

Also, have you tried power cycling the Core, Network and LS50s yet? I would give this a try by powering off, unplugging power, wait 30 seconds, plug back in and turn back on. Does that help?

Thanks for the suggestion and apologies for not replying earlier. The layout of my house means I cannot use ethernet cable without going to the considerable expense of having it run through walls and the ceiling - hence WiFi and I fear that may well be the problem, although every thing else connected (Smart TV, Yamaha network player, numerous radios) works fine. Roon looks like to much of a challenge which is a shame because it looks like a great interface. Tried power cycling several times without success.


While I don’t normally suggest these, but, you might try something like NETGEAR PowerLINE.

Hi @Bruce_Spencer,

I would try temporarily connecting the via Ethernet to see if there is a change in behavior, even if the router is located on the other side of the house, we can temporarily test this to see if WiFi is the culprit here and then continue on to next steps. We generally don’t recommend powerline adapters as @Rugby mentioned, but maybe giving this a try or a mesh-network kind of setup with an Ethernet out port will be helpful in your case.

A post was split to a new topic: KEF LS50W - Roon lost control of Audio Device

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.