Roon Mac remote high GPU utilization

@Dylan Interesting little app available at in case anyone missed that. I have noticed high utilisations too but its not consistant. Mine is set to Dynamic for the record and is a Radeon Pro 5560X

Hi Dylan,

The system is running in dynamic switching mode.
I bought the new Macbook and updated to Roon 1.7 at about the same time so I’m not sure where this began, but I never noticed this issue before these changes. I haven’t had any graphics issues with any other applications.

Thank you.

Hi @Gary_V,

Can you set it to Discrete Only and let us know if that results in any change?

1 Like


I switched to discrete and graphics processing switched to the Radeon GPU; the utilization was normal.
Upon resetting to dynamic mode it seems the problem has disappeared, even after a restart! Sorry to waste your time. It never occurred to me to try toggling this setting.

Thank you,

Hi @Gary_V,

Thanks for the update! If you see the issue return with the Dynamic settings please do let us know!

1 Like

I’ll be trying this too, but I also sometimes run a server core on laptop as well so will test both. 2018 mbp 15” i9 32gb

2 posts were split to a new topic: Mac Mini running sluggish with Roon maximized

Hi @Gary_V,

I wanted to check in with you to see if this issue has re-occurred?

We are currently investigating this behavior internally and if this issue is still ongoing, one thing that might help us better understand the issue is to install the Intel Power Gadget and share some screenshots of the GFX Frequency line when this issue is occurring. The screenshot would look like this:

If you have noticed the same behavior, I kindly request that you run this tool for both discrete and dynamic mode. Thanks!

Hi Noris,

Thanks for reaching out. Yes, the problem is recurring. If anything it is worse.
Here are the screenshots you requested:

Dynamic mode:

Discrete Mode:

Without Roon Display:

Hi @Gary_V,

Thanks for sending these screenshots over, I have forwarded them to the technical team for closer inspection!

A post was split to a new topic: Macbook Pro high GPU usage

Hi @Gary_V,

I spoke to QA regarding this behavior and we would appreciate some clarification regarding this issue.

  • Does this same behavior occur when you are on any type album details page?
  • If you open a single album or EP, do you still see this high GPU usage?
  • Do multi-disk albums with at least 5-6 disks consistently display this issue?


At this time I only see this behavior when the album is playing, it disappears if playback is paused.
The problem only occurs on the Tracks details page. There is no issue if Credits or Versions are selected.

The largest multi-disk album I have is 4 disks. The problem only occurs when either viewing the tracks of the currently playing disk or if the All Tracks option is selected.

I have also noticed that GPU usage drops in half if I scroll down the track listing until the cover art and synopsis scrolls off the screen.

Hope this helps.

Hi @Gary_V,

Thank you for providing that additional information, I have noted it with QA.

Hi @Gary_V,

One more aspect we’re considering here - does Roon get into this high GPU usage state when it’s opened on the album details page and the track which is currently playing belongs to this album or it can be reproduced by simply playing a random track and being on a random album details page?


It only happens on the details page of the track that is playing.

1 Like

Hi @Gary_V,

We’ve released a new update, Roon 1.7 Build 528, which contains a few graphics-related improvements. Can you please let us know if there has been any change in behavior with the new update?

Please see our full release notes below:

Hi @Gary_V,

Have you by any chance seen my previous message? Has there been an improvement in build 528? Please let me know when possible, thanks!

Hi @Gary_V,

I wanted to reach out to you again to see if you could let me know if there’s been an improvement here on your end regarding this behavior? Please do let me know when possible, thanks!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.