Roon MACOSX Trial Version Wont Open (just bounce and disappear)

I am on the trial version running High Sierra 10.13.4. When attempting to launch it wont open. The Roon icon bounces for a few seconds and disappear. Where do I go from there?. Also it does not appear in the activity monitor…so I assume is not booting at all.

My mac is a Macbook Pro (early 2015) Intel Core I5@2,7GHz with 8GH Ram Memory.
I have al my music in the same Macbook pro.

Any help appreciated.

Are you opening the Roon application from within the dmg disk image?
This behavior sounds like it. If so, copy the Roon application to your Application folder and try to open it there.

If this happens when double clicking the Roon.dmg file: Check if really nothing has happened. .dmg files are very common to distribute software applications. They are disk images and when you open a dmg file a new volume should appear that contains the actual app.
So, check if there is an additional volume by clicking in the Finder on “Go to” (in the top menu bar) and select “Computer”.

Thanks Ratbert…but I indeed copy the Roon app to the App folder…Im not opening from within the disk image. I actually rebooted the laptop and I have no other app running but it keep closing unexpectadly after several tries. Im new here…is there a way to send this to Roon Tech Support?. Thanks.

What Roon software did you install? Was it Roon Server or Roon?

Cheers, Greg

Roon, the name of the downloaded file is roon.dmg.


Let’s flag @support. In the meantime, do you have a firewall or antivirus software running?

Cheers, Greg

Hey @Enrique_Donoso — Sorry to hear you are having difficulties!

I have enabled diagnostics on your account so our technical staff can get some more insight into what’s going on here. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.


Hi in order to activate it do i need access to the application?..since I just downloaded today but I could not yet open it. Thanks.

Hi @Enrique_Donoso,

I wanted to reach out because I’ve been keeping an eye on our servers, waiting for the aforementioned diagnostics report.

It is not reaching our servers, even after I tried re-enabling diagnostics on your account. I also ran a quick test and I was able to submit a similar report from my setup here, so something else is going on.

So we can move forward, I was hoping for now you could use the directions found here and send us over a set of logs using a shared Dropbox link. We will need logs from your Core machine.

Thank you,

Thanks Dylan…the problem is that i can’t even open the app yet once…I will follow the instruction and let you know guys.

Many thanks!.


Follow the link to the logs file from my laptop. Hope its correct.

Hello @Enrique_Donoso — Thank you for sharing the logs here!

The technical team has reviewed the logs, and there are a few things here I’d like you to try out:

  • In your Security & Privacy settings for Mac, for the “Allow downloaded apps from:” option, do you have this set to Anywhere?
  • Do you have any antivirus or firewall running? If so, try disabling them.
  • Can you please share a screenshot of your applications folder, displaying Roon?


Dylan, my comments below:

1.- The option selected is Apps Store and Identified Developers…there is nothing like "allow downloaded apps from Anywhere.

2.- I have a firewall running…I disabled it and still the apps could not load.


The other thing to maybe consider is that Im working with a Mesh Wifi (TP-Link Deco) and everything is working fine but it comes with an Antivirus included that may be interfering but Im not sure how to disable it…the Antivirus Tab has three options (all selected) but all this is from the Iphone app, there is no Mac app.

Food for thought.

I already disable it but still not loading the Roon app.

Thanks for doing that for me, @Enrique_Donoso. Sorry to hear you’re still experiencing this.

Here is what I recommend trying next:

  1. Uninstall Roon
  2. Power cycle your device
  3. Reinstall Roon using these instructions.

Thank you,

Dylan follow all the instructions but, sadly, no improvement…the application won’t launch. I did everything…delete, reboot, download and re-install…deactivated the firewall and follow the terminal command as well.

Not sure what to do now.


In Spotlight Search type console

Now run Roon and see what comes up in the Console. You can filter for roon. This may point to the problem.

Thanks Martin. Here you have an screenshot after following your advise.

I could not take screen shot nor save the report so I took a photo but not sure you will be able to see it.

Pls let me know.

Easier if you press <command> + <shift> + <4> then press <space> on the Console windows followed by one click of your mouse … then upload. Thanks.

I think @support may be able to help here. It seems to be related to operating system capabilities, i.e. Roon is looking for something higher than yours seems to be returning. That’s my guess anyway.

PS. Can the nw_path_close_fd Failed to close guarded necp fd 20 [9: Bad file descriptor] errors be ignored? – they appear on my machine too.