Roon Migration Flub-up

I lost access to all my backup information while migrating from Room 1.8 to 2.0.

Here’s the story. I ordered a new 2022 Mac mini M1 to which I planned to move from my 2010 Mac Mini (which cannot be upgraded to Roon 2.0) which served as my Roon Core. By chance it arrived at the same time as the 2.0 release came out. I updated Roon and backed up Roon on the old Mac along with making a full time machine backup of the old Mac. Installed the new Roon 2.0 on the new Mac and went to restore the Roon 1.8 backup saved from the old Mac. No go. Version incompatibility. Roon 2.0 can’t read a backup made on 1.8. All my book marks, DSP settings, use history, playlists gone.

I still have the Roon backup BUT it was made under Roon 1.8 Build 1105. The Legacy version of Roon 1.8 is Build 1136, which is running on my old Mac now can’t read or restore my backup. I get the message “Restore failed. Please check backup folder and try again.” No matter how many times I check the backup folder it fails. Apparently Roon can’t even restore backups made with different Build versions? A pretty fragile backup solution! So I cannot even access or view my old backed up version of Roon on my old Mac.

Can anyone please help me out of this pickle? Is there any way to save my bookmarks, DSP settings, etc. and get them into 2.0?

Maybe you can revert your new Mac Mini to Roon 1.8 Legacy and then restore your backup. Then, put your new MacMini on Roon 2.0. Of course, there could be a problem with that backup. You might need to try a different one.

However, to my knowledge (which may be limited), backups are not version specific and certainly not build specific.

Thanks for the suggestion. If I had been able to restore the backup on my old Mac mini, which remained in version 1.8, but unfortunately got upgraded to 1.8 Legacy which is a different build, I would give it a try. But since I hit a wall even on that machine I think I need help from the tech experts at Roon.

Yes, in the case of V1.8 vs. V2.0 Roon has stated this is so and I know this is true from personal experience.

This is not true. Something else is happening. You mention Time Machine. How does that fit in with your Restores?

1 Like

My bad. I did not understanding you were agreeing with me. Thanks.

1 Like

He’s saying yes they are Jim.


The time machine backup does not really figure in to this. It is just there if I need it. However I should mention I have never does a full restore from Time Machine and at first glance it does not even seem like an option. So I would have to get into the specifics of which files and directories to restore and I am not certain of that.

What could be causing the error message I am getting? I have it pointed to the correct directory.

In the Roon migration instructions they seem to distinguish between restoring a backup before setting up the core and after the core is running. I am sure I tried it both ways but could this have something to do with it?

Nope it should work either way has for me.

Well I can’t seem to get any backup to run and the peculiar thing is the error message pops up immediately, so there must be something basic amiss.

@Bruce_Barbour, just to confirm, your Roon Core backup was created from within Roon under the Settings → Backup menu?

Do you have a list of recent backups that looks like this?

Yes to both questions. I have even tried restoring older backups from the list on the theory that maybe the last one was corrupt. But all behave the same. Error message as mentioned above.

Yes and the restore process look just like Jim_F’s image below.

Other than waiting for @support to respond, I would go to Roon 1.8 Legacy and see if that will let you restore your backup. Then, go back to Roon 2.0.

Thanks. I tried that already. Same problem, which is why I concluded above that the backups could only be restored to the identical build version. If that is not true then I don’t know what is wrong. I lost a lot of information built up over the last year and a half. I’ve got high hopes the support people can help, but they probably have a lot going on with the conversion to 2.0 and all.

1 Like

Hmm, how about using Time Machine to restore your old Mac, then using Roon to Restore a Roon backup? (Time Machine doesn’t restore the Roon database, very well)

Once that’s done, run a Roon Backup on the newly.Restored Roon and Restore that Backup on your new Mac.

Seems like a long way around, but maybe something that’s tangled up in its shorts will get straightened out.

You got nothing to lose and support might be awhile.

I thought about doing that to restore just the Roon app so it would be the same Build as my backup. What I don’t know is if there are other hidden associated files that also would need to be restored. There seems a fair chance that it just screws things up further. I would feel better about it if someone could tell me authoritatively that that is what needs to be done. After all if backups from different builds and even 1,8 to 2.0 are supposed to be readible it may be that I have some other problem and the whole restore procedure would get me nowhere. I’m inclined to wait for someone from @support to weigh in.

See, I am saying to restore the entire Mac from TIme Machine, then restore Roon using the Roon Backup. Don’t chose files; do the whole machine.

How? You are doing it on the old Mac and your new Mac is only getting a Roon database Backup to work with. As long as you have enough backups saved so that you don’t potentially overlay a good one, then there’s no problem.

Ok, understood. It might be awhile.

I’m going to have to study Time Machine a bit. Are you familiar enough with it to tell me how to do a whole machine restore? It appears to me that it is mainly file oriented but I’m probably missing something. I have let it do backups for years but have never had to do a restore.