Roon module for Home Assistant

You must still have a roon config in your HA config somehow (with the same host as you are adding).

Perhaps try rebooting your HA after removing the integration- and then try installing again.

Thx, the integration was suddenly in the “hidden” category…

Weird, but good you found it.

It it now working?

Yes it is working, thx alot

1 Like

Roon Remote

1 Like

Roon Tag

NFC inside,

when mobile closes to the tag, Roon starts to play. All are controlled by HA!


Interesting idea how to choose what to listen, is that some e-ink device with NFC capability?

Yes, you are right.
Another simple and cheap option:

1 Like


[Wireless knob controls Roon to play the cover display, stop the clock display - give the sound system a whole lot of high-tech]

Talking of wireless switches, I use a Philips hue dimmer switch to control a roon endpoint in my shower room.

I have a Zigbee hat on my home assistant Pi, and the buttons play my favorite radio station, control volume, and play pause.


【黑科技Hiend系统智能化升级语音选曲和播报正在播放的曲目(英文流行)】 黑科技Hiend系统智能化升级语音选曲和播报正在播放的曲目(英文流行)_哔哩哔哩_bilibili

can you please write your hardware (cover display and knob9? thanks

I installed the ControllerX but I have no idea how to do the button mapping and make the Ikea Symfonisk remote work with Roon, can you give some more detailed instructions? I have the IKEA gateway and the Tradfri integration installed.
Thanks a lot

Supported Adapters | Zigbee2MQTT

IKEA Symfonisk Sound remote - Tinkering - Roon Labs Community

Thanks all for the effort in getting this working. I’ve not only installed this within HA, but then used the Alexa integration to enable it there.

I use a Roon remote for most of my interactions, but like being able to us Alexa to control volume in one of the zone. However I’ve noted that by default the volume increase or reduction is quite severe , a change of 10db, I think.

Is there a way this could be configured to something less severe , say 5 db, and where would this config be stored or controlled


Great you have it working.

The home assistant integration converts room’s volume into the 0-100 scale that HA uses. This currently has a bug for some roon endpoints - so the first thing to check if whether the media player volume in HA moves sensibly. If it jumps with big volumes (rather than tiny steps), then you’re seeing this bug. I will fix this at some point.

If it does move smoothly then the volume step will be whatever the Alexa integration chooses - so perhaps look at the documentation for that integration. Afraid I don’t have an Alexa integration.

Let me know what you find.

I’ve found a workaround , via creating a Alexa routine which transmit a ‘increase the volume in the kitchen by 5db’ where kitchen is the name of the ROON entity. Seems to work and by created two routines for each ROON entity I’ve got better control. 5db seems a better default though

1 Like

I’d also say that the Alexa integration works better than I thought it would. I can’t see though what commands are supported , stop start, pause works , and for much more I’d probably use ROON remote

I made some changes to the volume control in an overriden Roon HA component, and for my Matrix Mini i3 the dB scale now works well (and also still works for my Hifiberry cards with 0-100% scale).

@GregD would be great if you could implement the code in HA: Volume control logic could be improved! · Issue #55 · pavoni/pyroon · GitHub