Roon "no audio devices found"

Roon Core Machine

Intel i3-10105, 8Gb

Networking Gear & Setup Details

Mikrotik 750gr3

Connected Audio Devices

Topping G5, E1DA 9038d

Number of Tracks in Library


Description of Issue

Good evening!
At first, Roon was on my laptop. Everything was fine, but I wanted to move the server separately. I installed CentOS 9, installed Roon Core, everything worked well. The laptop worked as a client, the smartphone on the road as a client. All well.
Recently I needed to reconfigure the network from to I reconfigured everything - everything worked, but the next day it started giving an error: “no audio devices found”. I did everything I could: rebooted, restarted the server (Core), deleted the RAATSever folder on both machines - all to no avail. Everything works fine on the smartphone, but don’t work on the my laptop. I still giving error: “No audio devices are detected.” What to do, how to solve this problem?

Are there any developers or support here at all? It makes no sense to use a product that doesn’t work.

Why did you do this?

I went through different options, searched on this forum before I did this. In one of the threads on the forum, one of the official support team recommended doing this if this error occurs. This action helped one person. It didn’t help me. The folder is still backed up, but that’s clearly not the point. I connected another machine to this Roon Core - the same thing. He doesn’t see a single device on the client machine. Could it be that Roon does not digest the network or is it used for other needs?

By the way, here is this thread and advice. True, I was mistaken in what the official support service recommended. But the moderator supported the idea))

I would first check to see that the RAATServer folders have been recreated on both machines.

The next thing to check is that the Firewalls on your machines have exceptions to allow the RAAT server communication to pass through.

BTW, the Support team is very small (less than a handful of people), they don’t work weekends, and they operate a queue system, which has rather a large backlog of issues at the moment, so it could be some days before you get an official response from them.

This is clearly not the question. Perhaps in the firewall, but before that everything worked. The firewall remained as configured as it was.

I have already completely reinstalled Roon Core with deleting all folders. This is no use. It doesn’t see any audio devices on my client machine.

Disabling the firewall on the server and client did not help.

I changed lan from and … nothing. What is needed this proram, that simple normal working?

I tried to read through RouterOS wiki/manual but its a PIA.
Anyway, I assume you set the dhcp server to
You will also need to reboot (switch off/on) all the ‘audio devices’ in order to make sure that they get a new IP address from the new dhcp pool. Also, if you have set any static IPs, you’ll need to switch them over to the new pool and reboot the respective devices.

No, I have static IP addresses. I use DHСP with a pool for WiFi only.
I have been configuring Mikrotik’s for many years.
And static IPs are not placed in the DHCP pool - these are completely different ways of organizing network. They can be used together, but not interfere with each other.

The problem is 99% in Roon Core. But what I don’t understand. There is a network between the client and the server, they see each other, Roon Arc works fine on the external network, but at the same time Rune Core does not see any audio devices on any computer with Roon.
We need some clarity on how Roon Core detects audio devices and transmits data to audio devices. The current manual is too simplified. What specific ports and protocols are used for this? Which services are responsible for this? Where are they configured? Configs, where are they located, how to change them?
Without this, it’s just fortune telling.

In general, I decided, but I still don’t understand what’s going on. I just changed the static IP of my Roon’s-client computer. If I return the IP back - it doesn’t work again.

Just that Roon devices are on the same subnet, that no critical traffic is blocked, and that the network has no issues generally.

The audio device discovery happens over the network, so the whole thing looks like a network config problem to me

Well, yes, Roon sees Roon Core, all the music from Roon Core is also visible, server is accessed from the client via SSH without any problem, samba works without any problem and everything is accessible without problems from the client machine, the only problem is that Roon Core does not see the audio device. Naturally, this is a network problem :wink:

And you need to check that multicast is enabled in your Lan

If you know so well, then you also know that protocol A can work and protocol B can fail on the same network because the protocols and the relevant machines differ.

But oh well, I will stop trying to help :man_shrugging:

1 Like

Apologize. I didn’t mean to offend you. Just jokingly pointing out the discrepancies.

Yes. That’s exactly how I set it up earlier.

In general, I solved the problem. I just changed my IP address to another one - nearby. Everything worked. But considering that there is basically no equipment with this IP address on the network (I scanned the network just in case), the reason is not clear. More likely, something with the program and its detection of audio devices.

There were none - as you found eventually :wink: