Roon no longer detects TEAC NT-505 on Windows 10

Core Machine (Operating system/System info/Roon build number)

Windows 10, Roon 1.8

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Netgear router

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

After upgrading to Roon 1.8, the device is not detected. No problems prior to the upgrade.

You’re using the NT-505 USB input, and its network port is disconnected, right?

That is correct.

Is the USB input selected on the NT-505?

Yes and it works perfectly with all other applications (Tidal, Qobuz, Amazon Music, etc.).

I’ve put my NT-505 in to my core via USB and enabled it in Roon and it works. The only thing I think it could be is selecting the correct drivers and ensuring it is enabled.

My core is a Synology NAS. I use my NT-505 as the audio output device for my PC, driving powered speakers and headphones. I checked the firmware on the NT-505 and it is current (1.22). Roon worked great prior to upgrading to 1.8. I submitting an inquiry directly to Roon Labs a few days again. Waiting, I hope not in vain, for their response.

Has the NAS received any updates recently?

No. Last DSM update was to Version 6.2.4-25556 on March 8.

Sorry, just re-read your opening thread. Is the Windows machine a Roon bridge?

The Windows machine is a PC with the TEAC NT-505 DAC/amp attached to it via USB. It is a Roon bridge.

The only thing left I can think of is to uninstall Roon and put it back on then go through the activation process again.

I did. Both on the core and the bridge. No dice. But I’ll do it again.


Has that helped?

Yes, it’s working now. Thanks.


It worked for a while and now it’s not working again. I’m very disappointed.

And no response from Roon Labs. Not good.

Have you applied the recent Windows 10 updates, there’s a good chance the USB driver may have been overwritten.

TEAC provide their own USB driver. install it over the one Windows has applied

I have installed the TEAC driver and it is being used.

roon app cannot see the device.

All other applications, Tidal for example, recognize the NT-505.

You may have already done this, but does your NT-505 have the latest firmware installed? There’s an explicit mention of Roon Ready on the Teac download page.

Stupid question but … is the TEAC Enabled in Settings > Audio , it hasn’t got switched off by accident maybe

Just a thought