Roon no longer playing on system output

Roon Core Machine

I think this has been asked before but not really answered. My Roon Core is on my Windows 10 PC with my music stored on a NAS elsewhere. Roon on the PC will play audio on any of my enabled speakers (eg. Sonos, Mu-So) but will no longer play audio on the actual PC itself (a pair of PC speakers simply plugged into the headphone socket of the PC’s sound card). It simply flicks through each track until the end of the album. I’ve tried disabling firewalls and Avast with no effect. Any other suggestions please?



Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I have noticed with me that only with connected USB-DAC also the system output can be displayed or activated. For the digital / analog conversion, such inexpensive solutions are already enough.

Then even a better quality comes out with further settings of the apps.

You probably have Realtek drivers installed for the internal sound card. If so, get latest Realtek Drivers from the manufacturer, not Windows update.

Thanks Dan… I’ll certainly try that but the audio plays fine from the PC with other apps eg. Foobar, MusicBee…


Hmm. Still updating the drivers shouldn’t hurt anything.

Then some other software on the pc is grabbing the audio device and not letting it go

I know the grapping with WASAPI (Exclusive), but the visibility would always be there. For me no Realtek driver helps, only a DAC. Is it possible that Roon is programmed so that the internal sound card is not always available for selection?

No need for a DAC that’s why roon asks users to try the system output.

DAC out means no display of devices for me. DAC in means all system devices are there also HDMI via NVDIA and everything that is installed.

Then your machine isn’t set up correctly.

I can even pull the DAC back out and the system devices stay there. It looks more like Roon than Realtek & Co to me. But is not a problem because I have a solution for it.

Thanks for all the replies guys…it was working fine up to a few weeks ago. If it was a sound card problem would Roon not simply play the track (but I wouldn’t hear it) as opposed to flicking through each track quickly. It’s almost like it thinks the tracks aren’t there…but they are…


Fast scrolling without playing was sometimes fixed with a complete reboot of all devices up to the router.

This happened to me when I created my ROCK/NUC it turned out to be a RAAT permission through the Windows 10 Defender Firewall. There are 2 settings Public and Private . In my case only one was checked …


1 Like

Thanks again everyone…I uninstalled Avast AntiVirus, rebooted and all working now. Previously with Avast installed I disabled all shields for10 mins but it still wouldn’t work so a full uninstall is the quickest cure. I wonder if most Roon users just use the built-in Windows 10 Defender for this type of reason…


I do , I just allow Windows to do everything (Blindly maybe !!) AV and Firewall .

Spoke to soon…worked for about half an hour, now back to flicking through all tracks quickly with no sound output.


Ok, I just tried playing a Westlife song (don’t hate me!) and checked the Roon logs immediately - see below. The error message that may be the culprit is “failed to sync clocks with any endpoints…giving up”…any ideas much appreciated.


06/02 12:44:15 Trace: [PC] [HighQuality, 16/44 TIDAL FLAC => 16/44] [PLAYING @ 0:00] Starlight - Westlife
06/02 12:44:15 Trace: [prebuffer] ready 149940/441000 (34%) @ 0/224 sec
*06/02 12:44:16 Info: *
–[ SignalPath ]---------------------------------------------
SignalPath Quality = HighQuality

  • Source Format=Flac 44100/16/2 Quality=Lossless*
  • Raat Device=System Output*
  • Output OutputType=Local_SharedMode_Wasapi Quality=HighQuality SubType= Model=System Output*
    06/02 12:44:16 Info: [stats] 13249mb Virtual, 5341mb Physical, 2371mb Managed, 3550 Handles, 217 Threads
    06/02 12:44:17 Warn: [PC] [zoneplayer/raat] failed to sync sender clock to endpointSystem Output: Sooloos.Broker.Transport.ClockSyncResult
    06/02 12:44:17 Warn: [PC] [zoneplayer/raat] failed to sync clocks with any endpoints…giving up
    06/02 12:44:17 Info: [audio/env] [zoneplayer → stream] All streams were disposed
    06/02 12:44:17 Info: [audio/env] [zoneplayer → stream → endpoint] All streams were disposed
    06/02 12:44:17 Info: sleep 0ms after flush
    06/02 12:44:17 Warn: [zone PC] Track Stopped Due to Error
    06/02 12:44:17 Info: [zone PC] OnPlayFeedback StoppedEndOfMediaUnnatural
    06/02 12:44:17 Debug: [zone PC] _Advance
    *06/02 12:44:17 Trace: [PC] [HighQuality, 16/44 TIDAL FLAC => 16/44] [STOPPED @ 0:00] *
    06/02 12:44:17 Debug: GMS: saving nav stack
    06/02 12:44:17 Debug: GMS: done saving nav stack
    06/02 12:44:17 Debug: FTMSI-B ti/5D136E52 download status: FirstBlockRetrieved accessTimeout:True openFiles:1 prev:(FirstBlockRetrieved,False,1)
    06/02 12:44:18 Trace: [upnp/discovery] device expired: uuid:90f51000-e480-43b6-9ceb-32ed87e26709
    06/02 12:44:19 Info: [library] saved recent ProfileId=766d5a0e-f2d5-47b6-9cfb-62f7a61eeb15 Time=02-Jun-22 11:44:17 AM DataType=album Type=long_nav MetadataId=21389433 ContentId=21389433 LibraryId=6850863 Text= Genre=
    06/02 12:44:22 Trace: [zone PC] [zone] no playback for 5s, suspending to release audio device
    *06/02 12:44:22 Info: *
    –[ SignalPath ]---------------------------------------------
    SignalPath Quality = Inactive
    06/02 12:44:22 Warn: inactive signal path :frowning:
    06/02 12:44:22 Trace: [zone PC] Suspend
    06/02 12:44:22 Trace: [zone PC] Stop
    06/02 12:44:22 Info: [zone PC] OnPlayFeedback Stopped
    06/02 12:44:22 Info: [zone PC] Canceling Pending Sleep
    06/02 12:44:22 Debug: FTMSI-B closed file for ti/5D136E52; open files:0
    06/02 12:44:22 Debug: FTMSI-B ti/5D136E52 download status: FirstBlockRetrieved accessTimeout:True openFiles:0 prev:(FirstBlockRetrieved,True,1)
    06/02 12:44:22 Info: FTMSI-B ti/5D136E52: allocated bw changed from 51200 to 0 kbps
    06/02 12:44:22 Info: FTMSI-B 1 FileCache ti/5D136E52 dwStatus:FirstBlockRetrieved files:0 accessTimeOut:True priorities: (‘zoneplayer:3’:16) → bw limit:0kbps
    06/02 12:44:22 Info: [audio/env] [zoneplayer] All streams were disposed
    06/02 12:44:31 Info: [stats] 13173mb Virtual, 5329mb Physical, 2371mb Managed, 3493 Handles, 198 Threads

Wild guess , your sound card is failing. There is obviously a DAC in the sound card that Roon would interrogate/communicate with , it seems it can’t

You don’t have any other DAC you could test , eg a USB DAC dongle ?

Do other apps play music through the sound card ?

Hi Mike

All other apps play through the soundcard no problem (Foobar, Musicbee etc.). Possibly a VPn issue but disabling it has no effect…