Roon not seeing Audioengine 2+ USB speakers

Core Machine (Operating system/System info/Roon build number)

Roon Rock NUC8i7BEH/Roon 1.8 790

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Asus DSL-AC68U>NUC (wired)>Win 10 PC (TP-LINK Powerline)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

USB. Audioengine 2+ speakers have inbuilt DAC

Description Of Issue

Speakers are not recognised under Roon audio settings. I’ve tried restarting my NUC.

Sound is fine generally on my PC.



Where are the Audioengine speakers connected the Win 10 machine or the ROCK NUC?

Win 10.

The first thing I would try is to turn off your firewall and see if the endpoint shows up in Roon (just as a test. If the endpoint does show up then you know it is a firewall blocking the NUC from discovering the endpoints on your PC).

Not official support just a helpful fellow user asking some prelim questions.

I’m afraid I’ve already tried that, but thanks for the suggestion.

Hi Daren,

From your screen pics, Roon does not show any audio devices on the Windows 10 PC, is that correct?

Also, did this setup work and suddenly stop, or, are you trying to set this up and have not yet gotten it to work.

If you search the Support forums there are potentially different causes for this. Here are a couple of threads to review:


Thanks for this.

VPN is a partial culprit. I can now see other devices with it turned off (not sure whether there is a VPN setting that gets around this) but not the Audioengine speakers:

I’ve rebooted the core with Windows Defender firewall turned off.

Looks like I’ll have to be brave and consider a new RAATService instance.

Hi Daren,

I still don’t see a Windows PC listed only a MAC. Are you using the Audioengine with the Mac?

My Mac is an endpoint. Obviously trying to make my PC one too (my core used to be on my PC FWIW and there were no issues with the Audioengines).

I would try following the link above with Dylan’s advice on generating a new Raatserver instance. But, you might also, uninstall Roon on the PC completely and then re-install selecting your ROCK NUC as the Core.

1 Like

Neither worked. Interestingly I did not lose any audio settings, contrary to the instructions. I have a new RAATServer folder.

Is the Win PC on the same network/subnet as the others?

Yep. If you see my screenshot, I can see my Mac and RPi as an endpoint.

Yes, but what is the ip address of the win10 pc the speakers are attached to?

Thanks for your time with this.


Ah, ok. Not the problem. Think I misunderstood the other screenshots. Hope you get it figured out. Obviously it should work.

Problem identified. It was Windows Defender - there are 3 protections to turn off - I think I only did two previously.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.