Roon not syncing with Tidal despite attempts to fix issue (ref#RH179M)

What’s happening?

· Something else

How can we help?

· None of the above

Other options

· Other

Describe the issue

I am running my Roon server on a dedicated Windows PC.

Roon is stuck on "Syncing library now" in the "Services: Tidal" menu in settings. However, in reality Roon isn't syncing to Tidal anymore.

I tried restarting, deleting the cache, reinstalling but none of these attempts helped. At some point, although Roon was still connected to Tidal, while "syncing" Roon removed all my Tidal albums from the library. I fixed this by restoring a backup from a few days ago, so those albums are now back in my library, but the syncing problem remains.

Thanks for your assistance.

Describe your network setup

don't know

Have you tried logging out of Tidal inside of Roon, rebooting the Roon Core machine and once back online log back into Tidal again?

1 Like

Thanks for the advice! I just tried that, but it sadly didn’t work.

Hello @Jeroen_Stevens ,

Thanks for your message. I noticed that you mentioned you tried reinstalling Roon, but have you tried to set the previous database aside as well? If not, can you please try the below instructions and let us know if this changes anything?

Let’s get you on a fresh database and see if your issues persist:

  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon Server” and “Roon”
  • Rename the “RoonServer” folder to “RoonServer_old” and “Roon” to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if the issue persists on a fresh database before restoring the backup

Here is the process outlined from a Windows machine:

All Roon_old on Windows

Hi Noris,

Thanks for your suggestion. I followed all the steps carefully but sadly this didn’t fix the problem (neither before nor after restoring the backup).

Hi @Jeroen_Stevens,

Thanks for the update - I believe you are experiencing a larger issue we’re currently investigating. Here is the tracking thread associated with it:

If you force a manual sync now, do you run into the same issue?

Hi Benjamin,

Thanks for following this up.

Could you tell me how to force a manual sync? Seeing as Roon seems to “think” it’s updating already I don’t know how I can do this.

(The problem remains after updating to the new Roon version.)


My apologies @Jeroen_Stevens I didn’t realize you were stuck in the syncing state. I hope to have more information from our development team soon.

In the meantime, a few users have successfully reported using a basic consumer-grade VPN temporarily, to change their location, which has seemed to help complete their syncing.

Note that using a VPN technically falls outside the scope of Roon Support, so this is certainly not a solution by any means, but rather a temporary workaround to bypass this thorny issue while we continue to investigate.

Tidal sync is working again! I didn’t do anything, no VPN, it just started working again.

Thanks everyone.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.