ROON not working after WIN 10 1809 upgrade

I’m getting the error message “An audio file is loading slowly. This may indicate a performance or hardware problem.”

I’m running the latest 64-bit version of ROON 1.5 which is connected to a NAS (M:) drive.

JRiver Media Center plays all files normally using the same setup.

Tried uninstalling/reinstalling. Reinstalled the drivers for my Schiit Jotunheim DAC. WASAPI works fine in all other applications.

You can find all of my log files here:!AtxDq8wvrmDMgcIjJk1wtlz-_iLFUg


Thank you

@Robert_Roper - I don’t think putting @support in the topic description will alert support. Anyway, I put in this post.


Hey @Robert_Roper,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Does this error occur when playing to all endpoints?

Are there any active antivirus or firewalls on the Core machine? If you disable them temporarily is there any change?


1 Like

This may just be a stab in the dark, but try to enable IPv6; enabling IPv6 fixes “Edge” network communication, which was broken after update to 1809.

@support I’m running the ROON core on a Surface Pro 3 connected thru a wired network to a Synology DS416play NAS. The network router/firewall is a Fortinet FortiGate 60D NGFW. (DNS is handled thru a Cisco Umbrella Roaming Client, hence the loopback interface IP for DNS).

WASAPI audio is thru a USB-connected Schiit Jotunheim DAC. The playback problems are occurring when this playback zone is selected. I tried switching the audio output to “System Output” and “Realtek High Definition Audio” (the Surface 3’s internal speakers) and neither of these outputs worked. Same error “An audio file is loading slowly. This may indicate a performance or hardware problem.”

There is also a network-connected Nvidia Shield device in my living room that ROON has recognized on the network, and when I switch to this zone everything works fine!

Disabling the firewall has no effect…the Surface 3 and the Synology NAS are both on the same internal network. ROON was functioning normally with this network setup prior to the Windows 10 upgrade to 1809. After the Windows 10 upgrade, I completely uninstalled and re-installed ROON. The music library loaded normally from the NAS and playback thru the networked Nvidia Shield works normally. The issue is playback directly from the Surface Pro 3 where the ROON Core resides.

Hope this helps. Thank you!

Thanks for the info @Robert_Roper!

Do you have TIDAL content in your library as well? Does that content experience the same behavior?

I’d like to propose a test that should help narrow down where the behavior is originating from. Can you temporarily move a couple files locally to the Surface Pro 3 Core and enable the storage location as a watched folder? If you play this content from the local storage is there any change in behavior?


I do not have any Tidal content in my library. I tried playing some files from a local folder on the Surface 3 (My Music) and the problem remains. No change.

Thank you, @support

I hope you did not discover a new problem along the 1000 other problems that they found with the 1809 update aka the October Nightmare Release.

I’ve been trying to get the update for the past few days and really glad I didn’t get it now

1 Like

Yes, I have heard about this, but other than this ROON issue I haven’t had any other problems!

I just went to the Settings/Windows Update page in Windows 10 on my PCs a few days ago and clicked the “Check for updates” button. All my PCs promptly downloaded 1809 and proceeded to install it. Fortunately, all my data appears to be intact (touch wood).

@support i have another problem with the win 10 N 1809 upgrade.
After the upgrade Roon won’t start and gives me the error: codecs are missing.
I have the N edition (without media pack - Europe) and with the previous version 1803, I just had to install the media pack to get all the necessary codecs. But with 1809 installing the media pack does not resolve this. Error message for missing codes remains. I had to roll back to win 1803.
so far I have experienced the same behavior on both my laptops…

EDIT: a reinstall of the media pack on the secondary laptop fixed the problem…