Roon not working with Argon Audio Solo

Roon Core Machine

Windows 11 21H2 Build 22000.1098, Dell Optiplex 3040 mini, Core i36100T 8GB RAM, Samsung SSD 870 QVO 1TB - Connected to Ethernet

Networking Gear & Setup Details

TP-Link AX1500 Wi-Fi 6 Router - Connected to Core via Ethernet. ISP is Virgin Media Ireland.

Connected Audio Devices

Argon Audio Solo connected by Wireless to Router (they are in the same room)
Chromecast Audio x 2 - no issues
Chromecast x1 - no issues

Number of Tracks in Library

513 Albums

Description of Issue

I setup the Argon Audio Solo via Google Home and it works perfectly with Google, Spotify, Qobuz and casting direct to the device from a phone. However, it will not work with Roon. At first, I got a couple of errors stating something like lost control of device, input switched. That happened twice and since I can select the Solo from the Roon Ready listing as enabled on the Core, but nothing will play from either a PC or Android phone. No error, it shows the message it is starting and then just stops. I’ve rebooted the Core and the Router, and, on some occasions, it works for a short while and then when I go to change the input from an album to a radio stream it just stops and will not respond. I can see the Chromecast and Airplay options to enable on the Core and have tried the Chromecast, but it is glitchy. I can see in the logs there seem to be issues with Roon interacting with the Solo. I upgraded the Core to 2.0 recently. ARC is not currently setup.

Do you know if the Argon is connecting via WiFi to your TP-Link router on the 2.4 GHz WiFi band? That router’s specifications show a very limited 2.4 GHz capability (supporting only 802.11n, or WiFi 4), and is very limited in capacity.

Can you force the Argon to connect to the 5 GHz WiFi band and see if this corrects the behavior you are experiencing?

Do your 2.4 and 5 have the same SSID?

And is your VM ISP box in modem mode or normal router/WiFi mode?

Yikes, just checked the TP-Link specs for 2.4, 300Mbps…I’d bet the VM ISP box can outperform that.

In the case of the 2.4 having poor bandwidth, I’d separate the 2.4 and 5 SSIDs.

1 Like

ISP Router is not in Modem mode yet, I have to do this to get ARC working. That aside, the Solo is connected on 5GHz. Issues remain the same. One thing I do notice is that the Roon Ready device disappears in Settings\Audio but the Airplay and Google devices for the Solo are still there. This seems to happen at random.

If you can set the ISP one box wonder into modem mode you’ll get Arc working. Pretty sure of that.

If the ISP box is also dishing out the same SSID for the 5ghz, it could be causing the issue with your Solo. Other devices can be less problematic.

Hi @Roger_Turner,

I read on the community that the Solo at first wasn’t Roon Ready and needed a firmware update for that. Could this be the cause of your problem?

It’s showing as Roon ready. There is no firmware update available from Argon’s website that I can see. Firmware version is p15245.125.0

Wi-Fi is disabled on the Hub 2.0, it is in Modem mode now, finally got a moment when everyone was out of the house to change it.

Can someone from Roon support reach out please? I have logs showing the errors, I just need someone to review them.

This was the topic I was refering to. But not sure if it applies to yours. Just for reference.

Thanks, I have raised a call with Argon Audio support to check


I built Windows 10 rather than Windows 11 from scratch on the same PC and gave it a different name. I then installed Roon 2.0 as a fresh install, removed the license from the old Core and re-imported the library and set up all the devices again. Now the Solo works perfectly. Thanks to everyone for your suggestions.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.