Roon now highjacking iPad volume since update [Roon Investigating]

Roon Core Machine

Not relevant, but it’s a Mac Mini.

Networking Gear & Setup Details

Not relevant.

Connected Audio Devices

Bluesound Node 2i via wifi.

Number of Tracks in Library

Not relevant, but fewer than 10,000.

Description of Issue

Since the latest update, every time that I open Roon Remote on my iPad, it resets the volume of my iPad to match the volume setting of the Node 2i that it is controlling. I have never played Roon through my iPad, not even once for testing. Once I realized that it was Roon that was causing the problem I went into settings and actually disabled the iPad in Roon, but the problem was not resolved.

I keep my iPad volume at around 20%. The volume setting for my Node 2i is usually around 80%. Thus, since I open Roon Remote on my iPad frequently to manage my main music streamer I now have the situation that when I start using something that actually does use the speakers of my iPad (Duolingo, podcasts, maybe a video from the web, etc.) my ears get blasted by the 4 x increased volume. I’ve looked at everything in the iOS Settings, as well as the Settings in Roon Remote, and I can find no way to fix this problem. Please help.

On the plus side, though, I do appreciate that Roon Remote no longer seems to crash about every fourth time that I open it. I’m in favor of updates, I just wish they wouldn’t try to deafen me. :wink:

3 Likes

Hi @Jeff_Melin,

We appreciate the feedback! I’d like to start by giving some insight into why this is happening:

With the latest release, we added the ability to use the hardware buttons on mobile devices to adjust the volume of your zones. Like all other apps that implement this feature, the volume of your iOS device and the volume of the device you’re controlling are synced in order to make this work.

As mentioned above, this is something that all apps that implement this feature do as it is a requirement of iOS, so unfortunately it’s not possible to modify this behavior.

I’ll be sure to pass this along to our team so they can consider the use cases where this might not be ideal. Thanks again for the feedback!

Wow. Just my luck that you should introduce a “feature” that will make me stop using Roon less than a month after I bought a lifetime subscription. How did you decide that it makes sense to sync the volume levels of completely disparate systems, and not let the user opt out of this “feature”? Is there some way that I can downgrade Roon Remote? Having it crash several times a day is by far preferable to having my ears blasted several times a day.

1 Like

@Jeff_Melin I think you can turn this new behavior off. On your iOS device, open the Roon app; in the Settings menu, choose Setup and then change “Enable Lock Screen controls (beta)” to No.

@Brian_Doherty Thanks for the suggestion, but I just checked, and that setting is already off. Back to BluOS for me…

As a long time user I love Roon!

I do up vote this as the bug of the decade, however.

1 Like

If I may have a suggestion and if it is actually doable: it would help if the app would restore the previous volume setting after being closed (swiped up in the app switcher). Also, if it is possible: to add another control to the Lock Screen: the ability to switch / transfer zones.

Sounds like this is the bug then. the volume sync is performed by iOS but with the setting off I don’t think Roon shouldn’t be modifying the volume at all ?

The issue that I’m experiencing actually has nothing to do with the lock screen. While fully logged into the iPad I open Roon Remote, and it instantly resets the volume of my iPad, which persists after I switch away from, or even fully close, Roon Remote.

Also, I think that the “Answered” note that has been added to the title is misleading. It clearly is not an iOS requirement that Roon Remote must reset the volume of the iPad, since it never did so before (and nor does any other app that I have ever used).

To clarify, this change isn’t due to the lock screen controls, which can be disabled. Roon can now use the hardware buttons on the device to adjust the volume of your zones even if lock screen controls are disabled. This feature requires the volume from the zone to be synced with the volume of your iOS device.

1 Like

Ok, I understand. So that means that there isn’t an option to disable the iOS hardware volume control for those people who don’t want to use it? I think there should be a way to disable either the Lock Screen controls and/or the device volume controls.

The reason I nominated this new “feature” as the bug of the decade is because it potentially can result in hearing loss. That is a pretty big bug!

1 Like

Hi folks, I just wanted to give an update that I talked to our product team about your feedback. I can’t offer timelines or provide specifics, but we are investigating what options are available to make improvements based on your feedback. Thanks to everyone who has reached out so far about this!

2 Likes

Don’t know if the following was reported already, I hope so but it’s highly annoying. Is Roon looking into it?

When I switch app on the iPhone volume is 100%:man_facepalming:

Sorry but it’s very irritating because no issues with other app.

Also behind the scène could you tell us more? Is it emulating AirPlay? No dev resources for a real iOS app?

2 Likes

Hi @Gigatoaster,

I moved your feedback over to the relevant thread. Please see my post about it here:

2 Likes

Thanks Dylan for the follow-up. Any info on my other questions you could share with us, by any chance?

Explained earlier in the thread:

Thanks Kevin. What about:

Also behind the scène could you tell us more? Is it emulating AirPlay? No dev resources for a real native iOS app?

Personally, I can’t provide any more ‘behind the scenes’ insight beyond what’s already been explained (I didn’t build the feature :slightly_smiling_face:). But if you have specific questions that haven’t been answered, let me know and I might be able to check with the R&D team.

I’m not sure what you mean by this, can you rephrase the question with more detail?

That won’t help here – native or not, the way hardware volume controls work in iOS doesn’t change. We’re starting to veer off-topic, but if you have suggestions for areas in the app that need improvement, don’t hesitate to submit or vote on a suggestion in #roon:feature-suggestions.

i have configured my streamer to fixed volume.
every time i open the roon app on the ipad the volume of the ipad is set to 0.
i never have the need to control the volume with the buttons on my ipad :wink: so this should be configurable or better be automatically disabled in case the volume can‘t be changed…

7 Likes