Roon now highjacking iPad volume since update

Same here with iPhone 12 iOS15. Other media apps always launch with 100% audio level now which is NOT pleasant. I lower it to say 20% and next time it’s up to 100% (which my Lumin/Roon setup is set to). It’s great if I can control my Roon end point volume but it must not overrun my volume setting for other media apps. Can I solve this by some settings?


I ran into this issue last night on my iPad. I was not using the Roon app at the time. I usually play one particular audio file before I sleep at a very low volume level using the iOS built-in audio player. To my surprise, it played at 100% volume.

I hope this issue is fixed soon.


“i have configured my streamer to fixed volume”. Ditto. Not much use as a feature, and stops me listening to other content on my phone. I guess it could be useful to control a Sonos via the Roon app, but that’s not exactly my primary use case.

1 Like

I’m adding my vote to do something about this terrible feature.

As my other post shows, not only is it annoying, it doesn’t even work! Both volume buttons on my iPad decrease the streamer volume. Come on.


The Roon Remote App on iOS is now unusable. when volume on my BlueSound speaker is on 18 about 60dB measured with dB power amp amp the iPhone volume is adjusted to about 20%.
This makes it difficult to hear the phone ring and also makes it super annoying switching between apps having to adjust volume between each app switch.

IMHO if this is how hardware button volume control is supposed to work on iOS then please revert to previous version functionality with volume control in the Roon App only controlling the playing device.

I am looking forward to this being fixed or removed so I can use Roon on my iOS devices again.


I my case the phone’s volume is also adjusted when I use the “software” slider in the roon ui. So even when I am not touching the hardware buttons, the device volume is changed.


[quote=“Roon now highjacking iPad volume since update [Roon Investigating], post:2, topic:172588”]
Like all other apps that implement this feature, the volume of your iOS device and the volume of the device you’re controlling are synced in order to make this work.

In auralic Lightning DS this is not the case in my experience.

Yes I also have that problem as well as the hardware buttons. the Roon volume control should not adjust the iOS device volume unless it is the endpoint.


This genuinely needs to be sorted as a matter or priority. Even with the option disabled in Roon, it still affects the volume on my remotes.


I have the issue as stated above, when I use the Roon app on my iPhone 12 it sets the volume to 100.

It is always pleasant when I forget to turn it down and I play a video at max volume.


exactly my issue too. would love to disable this feature.


Exact same issue here. I also have lock screen volume control disabled but am having the same problem with my iPhone volume being set to 100% each time after opening the Roon app.


Though I had only been using Roon for about a month before this problem occurred, I find that I am really missing it. BluOS is perfectly functional, but Roon is so much better (when it behaves).

Any word on when we might expect a fix for this issue?

This needs to be fixed ASAP - it is ruining Roon. I’ve been a subscriber for several years and this is the first time I’ve felt compelled to respond on the forums - it is completely unacceptable behavior. I’m going to be forced to stop using the platform if this isn’t corrected in the next few days. I am done. I use 2 primary endpoints. Downstairs volume is fixed so it zeros out my phones volume, and upstairs it’s almost always between max or 50% so my volume shoots up. I’ve deleted and reinstalled on my phone (13 pro max) twice, I’ve rebooted several times. I’ve checked the option in setup off and on and off. I’ve reduced all of Roon’s permissions on my phone - it is just flatly unacceptable behavior period. And no - my Denon and HEOS apps use the volume button, as does my TV and Apples own Apple TV remote, and they don’t exhibit this.


To add my request.

Please make a configuration setting which let’s me completely disconnect the iOS volume level and volume controls from the roon app.

I find the new connection between the iOS volume and the roon app very annoying and also disturbing.

I do not want that roon changes my iOS volume level.
And I certainly do want iOS to change my roon volume level.

At the least I should be able to configure that the iOS volume interaction is completely disabled for all other zones than the local iOS zone.

Thank you.


Yes, please fix this.


I’m adding observed behaviour in hopes of getting this fixed.

After being blasted by full volume at 100, this unexpected iPad behaviour which is the result of enabling lock-screen controls, I decide to turn this feature off. But volume control is now high jacked. I have been able to reproduce this behaviour:

  1. Turned off lock-screen controls, forced quit the app, and restarted the core.
  2. Open the app and confirm the iPad volume is at 7.
  3. Switch zones to ChromeCast, which is set to 100 for powered speakers.
  4. Play some music for about minute.
  5. Stop music.
  6. Return to iPad zone and confirm volume has been changed to 100.

I have taken a video of this and have been able to repeat it multiple times.


1 Like

This is kinda annoying? :imp:
Every time i switch to Roon on my iPad Pro 12.9" 2020 the volume on the iPad get set to whatever volume is set to the current endpoint. (All of my endpoints but one employ fixed volume, so 0 is the common result)
I have NEVER enabled “lockscreen controls” on this Core, and it doesnt seem to matter if the iPad is even listed as an available endpoint. (It was never chosen as output in this situation)

So volume is muted on my iPad every time i have used Roon, which is causing me to miss conversation, calls and notifications. This is not an Apple issue, as no other of my music apps have the same annoying behaviour…

1 Like

Just weighing in to say I thought I was going nuts imagining this… misery loves company I guess.

Please fix this Roon - it’s the biggest bug I can ever remember in your software. Hopefully it’s a priority.


My iPad and iPhone go to full volume setting in iOS overall control any time Roon app is opened. Please fix this asap, it’s quite upsetting to my wife and I find it a nuisance at best. Thanks!