Roon Nucleus - cannot update to 1.8

Core Machine (Operating system/System info/Roon build number)

Roon Nucleus doesn’t want to update to 1.8. Tried updating on my smartphone, either just sit there or starts, does nothing for 10 mins and goes back to previos screen OR starts update for approx 10%, sits there or restart, etc etc.

Tried many many times. NOT GOOD at all.

Now I can’t use my Nucleus.

Your response would be appreciated.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue


Have you tried to reboot the nucleus?

Hello @Corey_Tai, our apologies for the trouble here. Are you able to connect to the Web Admin Interface? Can you share a screenshot? Also, I wanted to confirm whether or not you’ve rebooted the Nucleus since this started occurring.

I have a same problem, rebooted and the same issue occurs. I cannot use my system! Please help us

Yes I can connect to the Web Admin I/F but only if I use my Mac MIni as the Roon Core.
Cannot even open Nucleus as the Core…just asking to update and then doesn’t update.

yes I have rebooted the Nucleus many times but still same issues. Just doesn’t want to update my Nucleus.

Hopefully Roon support can help. Just doesn’t want to update my Nucleus to latest version

Yes many time but still cannot update…thanks

Hi @Corey_Tai

Can you try reinstalling the OS from the Web UI? Any change after?

I am having the same issue – I have re-installed the OS on my nucleus, re-started, and tried downloading and installing 1.8 several times. It got further the first time after I re-installed the OS, but still eventually stalled and terminated the download.

  1. Have reinstalled Nuclues OS
  2. Tried multiple times to update Nucleus Core to v1.8

Same update failures. See Screen Shots

Add images

![Screen Shot 2021-02-11 at 9.22.27 am|690x406](upload://eO1hca7p9Uit9yU6tVTNXZkA52X.png) ![Screen Shot 2021-02-11 at 8.38.55 am|690x477](upload://yCNQYbrFeDqHvehhOFc1yHw6Lmp.png) ![Screen Shot 2021-02-11 at 8.35.52 am|690x427](upload://wJH195TroAs7eeJq29wPfO42DWc.png)

Roon support just not listening or investigating. They keep asking try reinstall Nucleus OS (done that many times), try updating again (done that many times)

Need to get them to look why we can’t update…

Lot of their servers are overloaded right now. I would bet that’s the main reason. By retrying at a different time, you may have a better shot at getting this to work.

Is that the ultimate solution? No, but fixing overloaded servers while there’s an overload? That’s maybe less trivial than we all think. Future improvements on the update mechanism to retry an update without having to restart the server would also be a welcome addition.

I have been trying to give them the benefit of the doubt, but am getting pretty irritated. My phone auto-updated to the new Roon Remote software, which won’t recognize 1.7 and wants to force an update. Fortunately, my iPads didn’t auto-update, so I can still use 1.7 with them. But I am looking at alternatives – this rollout is a train wreck.

@david_whitaker Have you actually updated your core to 1.8? When you say ‘this rollout is a train wreck’ is that your impression or your experience, can you be more specific?
I and many others had no issues with the update although I acknowledge some users did.

There have been multiple reports across the Web of downloading issues and immediate operational bugs. It is particularly annoying to discover, as the owner of Roon’s own equipment, that they mucked up the downloading to their own hardware. I was referring to trying to update my Core to 1.8 - that’s what won’t work. I have been using, updating, and troubleshooting my own computers and network connections since 1984, so I’m fairly confident that I know what a good and lousy update rollout looks like, and how to handle minor update glitches (I’ve dealt with hundreds, if not thousands), and this is definitely a screwup.

So you have a Roon Nucleus? I guess you have already tried reinstalling the os? Power cycling, taking the setup back to basics etc, all things I have used since 1983 as a commercial network engineer.
I have an Intel NUC running Rock, iPad, iPhone and MacBook Pro, all updated first time with no issues.

Yep, did all of the above, plus checking network security settings, firewalls, etc. Roon Remote loads just fine – it’s just updating the Core on Nucleus that’s the issue. And, I would still think it was just me screwing up, were it not for the multiple reports by others. Oh, well — I’m sure it will shake out in the next few days…

I hope it gets sorted out for you quickly.

Thanks. Not good that Roon’s own gear doesn’t update correctly…