Roon Nucleus - cannot update to 1.8

Exactly. Updated my Mac Mini Core first time. BUT cannot update to Roon’s own hardware. Amazing

Update Roon’s own hardware - Nucleus is the problem. Just doesn’t want to update to 1.8 and now cannot play via the Nucleus. I have to login my Mac Mini Core.

Hi, I have the nucleus+, did the update on remote device as well.
I got nothing at all, my ipad mini is my remote, both updated
ipad Roon display says "Choose your Roon Core
That’s it.
Have you had any success?

Yes, it finally loaded. Don’t know why – I didn’t do anything beyond what I already described in this thread. But, this afternoon, I tried again, and it worked. My assumption is that Roon figured out whatever the glitch was and corrected it.

Hi. Great for you. Will try when I get home. Hopefully it will work…

Hi @Corey_Tai

I just wanted to check in and confirm that you were able to get updated. If you’re seeing any issues still let me know!

Yes thanks.
The 2nd problem after Nucleus update success was Tidal went missing. After a day or so, it can back.

This 1.8 update has been a disaster for me and it seems to many others.

New problem, on my Android phone Roon App doesn’t want to open. Opens on my Mac and iPad.

Any suggestions?

Really Mr Roon, much much better and longer Beta testing next time.

And an announcement on the issues would be nice ???

I have the same problem. I want to try and download Roon 1.8 to my Nucleus, but when I try I get the same user message as shown above “Software update needed. Roon is trying to connect, but it looks like one or more of your devises on your network need a software update”. I have checked all the devises on my network and none of them need an update accept the Nucleus, which I can not connect to. My Roon Nucleus use to work so well and I was so happy with it, but now it is dead in the water and no longer works. Very frustrating.

A post was split to a new topic: Roon Nucleus - Cannot Update