Roon Nucleus repeatedly crashing w/message "There was an issue loading your database"

– Roon Nucleus purchased 12/3/2019 (now 4 years old).
– Internal Storage: Samsung SSD 860 EVO 4TB, 2.5 Inch SATA III SSD (same age as Nucleus); 2.98 TB is still unused.
– 3,153 albums total (20,067 tracks); 1,459 are on Nucleus Internal Storage; 1,694 are in TIDAL library, not close to approaching Nucleus capacity of 10,000 albums.
– Roon Nucleus is outputted via USB-2 to Benchmark DAC2 HGC D/A Converter; Nucleus has a dedicated static IP address and is accessed through multiple iPads; no other endpoints are utilized.

For well over 1 year (perhaps closer to 2 years), my Roon Nucleus has randomly crashed several times per week, sometimes several times per day. The error message is always “There was an issue loading your database.” I have temporarily resolved this each time by doing a simple reboot via Nucleus Web UI. When I first did this, it was with the thought that the Core might just be in a bad state. While this always has fixed the immediate issue and enabled playing music again, this quick fix has never had a lasting effect beyond a few hours or days, and whatever is the underlying problem persists.

Besides the inconvenience of abrupt crashing while playing music at home, I cannot reliably utilize Roon ARC during my frequent travels due to the high frequency of Roon Nucleus crashes, each time making my Roon Nucleus inaccessible via ARC. My particular issue is present in current Roon 2.0 (build 1353), but goes back to earlier versions of Roon. I have seen no apparent pattern to how this might or might not correspond to any particular Roon activity. The crashing does not depend which of multiple iPads I happen to be using at the moment as the Roon remote.

I was so busy since this problem started that I simply have had to put up with this repetitive annoyance. I am finally able to make time to seek help to address this problem.

Based on an October/November ‘22 Roon Community thread in which Norris of Roon Labs Technical Support got involved, I temporarily tried setting both “Background Audio Analysis Speed” and “on-Demand Audio Analysis Speed” to Off. However, with these turned off, Roon crashed again within 1-2 hours of playing. Both settings were originally set to “Fast.” Currently, I have “Throttled” selected for both settings. (Nucleus crashing on Roon 2.0)

Earlier, I had tried a more extensive set of steps on the premise that my database possibly became corrupted. The steps I took below followed suggestions made within other various Roon Community threads to users also experiencing frequent crashes. Unfortunately, following this longer set of steps did not make the problem go away:

  1. Create a fresh backup (In Roon, go to Settings, Backups tab, Backup now)

  2. Use link http://nucleus.local 2 (or to pull up Roon System Status in Nucleus Web UI.

  3. In Nucleus Web UI, stop Roon Server Software from running.

  4. Navigate to Roon database location; for a Mac, in web browser, navigate to smb://NUCLEUS/Data. (If needed, use Guest both as the username and password.)

  5. Rename RoonServer folder to RoonServer_old.

  6. Return to http://nucleus.local 2 to pull up Roon System Status again.

  7. In Nucleus Web UI, restart Roon Server Software to generate a new Database. This creates a new RoonServer folder, with subfolder and contents,

  8. Reinstall Roon Operating System from the WebUI. Even if Roon Nucleus is already running the latest version, it will be overwritten by the Roon OS reinstall.

  9. On one of the Roon Remotes, press “Use Another Core” and connect to the new database.

  10. If everything starts up as expected, restore a Backup from prior to the issue starting.

  11. If the database restored from backup loads properly, edits, playlists, tags, settings, and preferences should be intact.

  12. Do screenshot of Roon System Status after above steps have been completed.

As I said, the 12-step process above did not make the problem go away, very possibly because the backup I used to restore (the oldest one I had) did not predate the problem. Since my problem started quite a bit further back than 1 year ago, any backup I am able to restore is almost certainly not older than when the issue first started. Roon for me has been set to do scheduled backups every 4 days, for maximum 99 backups saved, but this equates to only slightly >1 year to the oldest available backup.

Here is the Roon System Status screenshot taken immediately after I previously followed the above 12 steps:

For comparison, the next Roon System Status screenshot was taken today, after some time had elapsed since I had tried the above 12 step process:

I am at a loss and could really use expert assistance. What steps should I take to make my Room Nucleus reliable? Thank you in advance!

Hey @Jonathan_Dean,

Thanks for taking the time to write in and provide a thorough breakdown of your issues so far!

I’ll go ahead and enable diagnostics for your account so I can review the logging for clues. If you’d rather do it yourself manually, please use the directions found here and send over a set of logs to our File Uploader.

For traces of corruption, this is a common first step in troubleshooting, I’m sorry to hear your issues persisted after giving this a try! We could be dealing with hardware corruption, like SSD failure, or it could be coming from your database like you mentioned above, in which it sounds like your only option would be to start from a completely fresh database which is less than ideal.

Thanks Johnathan, I’ll be on standby for your reply. :+1:

Hi Benjamin,
I sure appreciate your response and willingness to help.

I am completely OK with you initiating diagnostics from your end.

To enable your diagnostics, does it make any difference whether I keep playing Roon in the meantime? For the last couple of days, I have been paying close attention to whether I am playing music from my internal drive, vs. Tidal, vs. Roon Radio to see if there is any common denominator on that front. (Oddly, my Roon Nucleus has not crashed during that couple days, which is totally uncharacteristic. Sort of like when one takes their car in for repair and at that moment things seem perfect.)

Thanks again, Benjamin!
Jonathan Dean

1 Like

Hi @Jonathan_Dean,

Based on the diagnostic report we reviewed, we do see traces of SSD failure in your Nucleus log. If you’re a bit more tech savvy I could share a breakdown of what it would look like to replace the M.2 SSD yourself manually, or we can get you set up with an RMA to send the device in for repair.

Since the device is outside of the 2-year warranty window, there would be a cost associated with the repair if sent in.

Let me know your thoughts and I can get you squared away! :pray:

Thanks, Benjamin, for the diagnostic and your quick response today, much appreciated. Yes, please do send me the latest version of the process I should follow to replace the SSD in the Nucleus and migrate everything properly and in the right sequence. I’ll get a new SSD on order right now.

Jonathan Dean

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.