ROON NUCLEUS + unable to connect remotely

Core Machine (Operating system/System info/Roon build number)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

I see the Roon Nucleus+ on the network but I can’t get it to play from my iPad. The remote app can’t find the Nucleus.
Description Of Issue



So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Are you able to access the Nucleus Web Administration Interface?

Are other remote devices able to connect?

I have a Roon Nucleus + unit connected to a Teac NT-505 by a USB cable. The Teac unit is a preamp with a built in DAC. I have an Apple iPad being used as a remote for the Roon application. The iPad doesn’t see the Roon Nucleus + using the USB cable, all it sees is the Nucleus with the HDMI connection which I am not using.

Thanks for you help. Ken

The NT-505 needs to be changed to USB input first.


After changing the NT-505 to USB input as Peter suggested is there any change in what you see here?

The NT-505 is set to USB input already and the iPad doesn’t see that input. What it sees is the HDMI input which it is NOT connected to and that’s it.


Thanks for confirming. Do you have a Windows or Mac remote that you can temporarily connect this device to? When connected to one of those devices are you able to see this device in Roon?

Just as a note, HDMI is always visible regardless of whether or not there is a device connected.

The device is connected to an Apple iPad and the Teac NT-505 is connected by a USB cable.


Just to confirm, have you tried using a different USB cable?

If you’ve tried that and there’s no change, I’d like to enable some diagnostics so the technical team can take a closer look. Before doing so, I was hoping you could do the following:

  1. Reboot the Nucleus
  2. Connect the Teac NT-505 to the Nucleus via USB
  3. Navigate to Settings | Audio and confirm that this device doesn’t appear here

Respond here with the time you’ve done the above and I’ll enable diagnostics so the team can take a look.


  1. I rebooted the Nucleus.
  2. I connected the Teac NT-505 to the Nucleus via USB.
  3. The device DOES appear but I can only see Nucleus for HDMI and don’t see USB setting.

I am having an issue with installing Roon remote on the iPad. I can’t install it and it acts like it is already installed.


I’ve tried enabling diagnostics on your account, but the diagnostics report never came through. I ran a few tests and the diagnostics tool seems to be working, so it looks like there is something else going on here.

So we can move forward, I was hoping for now you could use the directions found here and send us over a set of logs using a shared Dropbox link. We will need logs from your Nucleus.

Do you receive and particular errors when trying to install? Can you share a screenshot of what you see?

Here is the Dropbox link to my logs under KEN BECKLES.


Thanks, I’ve passed this over to the team. Can you also send us the RAATServer logs?

Just to confirm, have you tried the following that was mentioned above?

  • Connect the Teac to a Windows or Mac remote
  • Try using a different USB cable


Here is the link for the Roon Raat files

Thanks, @KEN_BECKLES. I’ve passed this along to the team as well and will let you know when I receive their feedback. In the meantime, have you tried the following?

  • Connect the Teac to a Windows or Mac remote
  • Try using a different USB cable

Can you also share a screenshot of Settings | Audio?

Yes I connected the Teac to a Mac remote, no change.

Yes I tried a different USB cable (3 different ones).

I will take a screen shot of the settings l Audio and send it to you.

Ken Beckles screen shot.


I’ve passed all of the above to the technical team, I’ll reach out ASAP when I have their feedback here.


I spoke with the team and they noticed that your Nucleus isn’t on the latest version. Can you try updating your Nucleus and see if that helps? Can you also confirm the Teac is on the latest version?

Additionally, can you confirm that things work as expected as a Roon Ready endpoint when playing over the network instead of USB?