Roon on Catalina crashes after using volume keys

I’m having the same exact issue on same OS version (Catalina 10.15.1)

Hi @Steve_Allen,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

The latest error occurred 191107.2038 EST

It happened again 191107.2110 EST

Thanks for the timestamp here, @Steve_Allen!

Can you give some additional information about the Core machine?

Sure, it’s a Macbook Pro mid 2015:

Hardware Overview:

Model Name: MacBook Pro

Model Identifier: MacBookPro11,4

Processor Name: Quad-Core Intel Core i7

Processor Speed: 2.2 GHz

Number of Processors: 1

Total Number of Cores: 4

L2 Cache (per Core): 256 KB

L3 Cache: 6 MB

Hyper-Threading Technology: Enabled

Memory: 16 GB

Boot ROM Version:

SMC Version (system): 2.29f24

Actually, the MacBook is the controller. The core is a QNAP TS-453Be NAS:
. Firmware version:
. CPU: Intel Celeron J3455 @ 1.50Ghz
. Memory: 8Gb

Thanks for the info, @Steve_Allen!

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

ok, thanks. Occurred again 191109.1032 EST.

Same problem persists.

Hi @Steve_Allen,

I wanted to reach out because I’ve been keeping an eye on our servers, waiting for the aforementioned diagnostics report.

For some reason it is not reaching our servers, even after I tried re-enabling diagnostics on your account. I also ran a quick test and I was able to submit a similar report from my setup here, so something else is going on.

So we can move forward, I was hoping for now you could use the directions found here and send us over a set of logs using a shared Dropbox link. We will need logs from your macOS Catalina remote.

Here ya go–it crashed 3x in row this morning.

Hi @Steve_Allen — It looks like these are the logs for RoonServer on the Core machine. Can you send over logs from the Mac remote?

Mac remote logs can be found here:

It crashed again this morning after installing Roon 1.7 build 505

You can find the location here: For the remote, the folder will be called ‘Roon’ (instead of ‘RoonServer’).

Thanks, @Steve_Allen.

I’ve passed along the logs to the technical team for analysis. Please keep in mind that due to the holiday weekend the queue for the technical team may take a little longer than usual, but I’ll be sure to reach out as soon as I have their feedback.

Hi @Steve_Allen,

I wanted to reach out and let you know that the team is investigating this issue, but in the meantime, you can avoid the crashes by removing Roon from the Accessibility options in the Mac’s settings.

Thanks, I tried to uncheck Roon from Accessibility, but it wouldn’t let me uncheck it. After Googling, this did the trick:

tccutil reset Accessibility com.roon.Roon

Volume keys worked without crashing after that.

Hi @Steve_Allen — I’m glad that things are working with you now. The team is continuing to investigate this so Roon can be added to these settings without this issue occurring, but in the meantime you should be all good to go here.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.