Roon on iPad etc keeps losing contact with my Nucleus

Roon Core Machine

Core: Nucleus.
Remote: iPad

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Sometimes after only a few minutes my Roon app loses contact with the Roon Core. It usually manages to reconnect for a while and then it happens again.

I have tried changing the Ethernet cable but that didn’t work.

Hi Adrian
Do you mean that the iPad is only acting as your roon remote ?

Hi Steve

Thanks for the response.

I use the iPad app to play the music and after a few minutes the music stops and it comes up with the ‘lost connection’ message. It then tried to reconnect and mostly succeeds but then it happens again.


You will need to provide more info about the set up , sounds Networky !

How is the core connected to the router for example

Are you listening via the iPad or controlling other devices

iOS has a habit of putting apps into the background if you are doing other stuff on the ipad

Hi Mike

The Nucleus is connected directly to the Router. I don’t play music on the iPad, I use the app to play music through a Naim streamer. Most of my music is on a Naim uniti core. I also have Qobuz.
I have been using the Nucleus for over a year in the same way without a problem. This is a recent issue.


@Adrian_Howe, how is your Naim Uniti Core connected to the network, directly to the router, a switch, or to an access point with an Ethernet connection? Can you provide any additional information on your WiFi network (brand, model number, is this a mesh system) and the type of iPad (year and size typically, and if it’s a mini, Pro, or normal model)?

The Core and the Nucleus are both attached directly to the router, which is Huawei G4. Not a mesh system.
The iPad is a 2016 9.7 inch pro.


I should also mention that I have the same issue when I use my iPhone XR as the remote.


I have the same iPad but don’t have any connection problems. This may be due to an issue with your WiFi if both your iPad Pro and iPhone XR are having similar behaviors. Can you describe how your WiFi is set up? I can’t find any information on your Huawei G4 router.

Sorry, could you explain what you mean by ‘how it is set up’?

I don’t have this issue when using the Naim app to control the streamer so I thought there might be a problem with the Nucleus?

For example, does your WiFi have only one band, two bands, three bands, if they are multiple bands are the SSIDs separated or identical, etc.

Ah right! It has 2.4 and 5 ghz. Is that what you mean? Apologies for ignorance but it was set up for me.

That’s perfect, thank you and no worries. Do you know if you have a separate login for either the 2.4 or 5 GHz bands? If so, it may be best to connect to the 5 GHz band as there is more capacity and less interference compared to the 2.4 GHz band. If the router chooses this for you automatically, there may be a way to force a connection to one band or the other.

According to the router manual it can be changed on the router’s web management page but it is refusing to accept the password.
In 2 weeks I am having full fibre broadband installed. If you think the issue is network related then perhaps I should wait and see if that solves the problem. Unlike the mobile network it will be stable. If it doesn’t I’ll come back.

1 Like

I don’t think it is necessarily related to your outside network but you most likely will receive a new router when you receive the fiber service. If you can live with this issue until then, yes please check in after the fiber installation and let’s see if the problem goes away with the (hopefully) new router.

Yes, there will be a new router. Let’s hope that resolves the issue. Thanks very much for your help.

1 Like


Sorry been offline

My system is NUC ROCK ethernet to router
Ethernet to local switch
Ethernet switch to Naim Unity Atom HE

Ipad pro 12.9 for control

Sounds quite similar. Needless to say mine works fine .They all say that

A few points

Do you use the ipad for anything else while listening, iOS has a habit of closing down dormant apps , so they need restarting. That said this sounds like a WiFi drop connection to the iPad, so you lose connection to the core. I have a WiFi repeater in my listening area to boost wi fi . I only use wi fi for control

Maybe download a signal strength app , there several freebies , you can get an idea of signal strength and in some cases congestion on the various bands. Are you using 2,4 or 5 Ghz,

2.4 is more congested depending on where you live , neighbours etc but 5Ghz is absorbed more by brickwork etc

Hi. I think we have concluded that the problem is either with the router or the Nucleus. Hopefully it’s the router as in a couple of weeks I’ll have full fibre broadband instead of the unreliable mobile broadband I have at the moment.
The router has both 2.4 and 5 ghz but it is only accessible via the router’s web management, which is refusing to accept the password.

Hi @Adrian_Howe,

Judging by the timing of the recent posts, you’re likely replacing your internet provider any day, so this post may be extraneous.

However, the tech support team has attempted to pull diagnostic logging from your Nucleus for more precise insight into why the iOS remotes are rhythmically losing connection to the Core. It appears the Core was offline - if possible, please keep your Nucleus online overnight at some point over the next few days at your convenience so our team can access the log report.

We’ll be standing by in case you have any issues after testing with the new fibre connection.

Hi Connor. My new broadband cable is being installed tomorrow so I have disconnected everything. The core should be back online by this time tomorrow.

1 Like