Roon on Mac can't find remote library since update [Solved]

Hello. I have my main library running on a Windows PC and use iPads and Surface pro and Macs to control it. Since the update to 1.2, my Mac can no longer see the library. All the other machines see it fine and work. I have tried deleting the Mac sw and reinstalling it but it still doesn’t work.

Hello Adam,

I suppose that you’ve already checked network connection on your Mac and it’s working fine ? If so, can you try to disable firewalls on both machines (Win PC with the Library and Mac) restart all instances of Roon and see if Remote was able to discover the Library ?

Thank you @Adam_Crafton

All network connections have not changed an all are working. No software has been modified or updated other than Roon. I disabled the firewalls. . nothing. Note that my iPad and windows clients have no problems, just the mac.


Hey @Adam_Crafton – sorry for the trouble here.

Can you be more specific here? Since you have an iPad and a Surface connecting to the Windows Core without issue, this really does point to something specific to networking on Mac. Have you disabled the firewall there, or just on the Core?

Can you tell us a little more about the Mac, and about your network generally? Does everything connect via Wifi? What network hardware you using?

Thanks for your near realtime support! I disabled it on the MAC.

I reset everything (all machines and network) and nothing. . but this morning it found it. Not sure why but it appears to be fixed. thanks.

Hmm, ok – let us know if the problem comes back and we’ll take another look. Thanks!

It is no longer working. .stopped a day or so after I thought it was fixed. The mac is the only thing that can’t see the roon server. . .all other devices can. It is only 1 mac as well… the other mac’s see it and work.

Any ideas here? I am sure it is the one Mac but I haven’t changed anything (that I am aware of) and not sure where to look.

Let’s start from the very beginning here. Can you please describe your network topology ? Can you verify that your Win machine and Mac are located on the same network ?

Similar problem here. Roon library is running on a headless Mac Mini in the same wireless network. I am using an iPad as remote which is working fine. When trying to use my Macbook as remote, it can not find the library.
Disabled all firewalls.
Running El Capitan on my Macbook and Yosemite on the Mac Mini.

Yes, all my machines are running on the same network. The headless pc running RoonServer is hardwired to an Asus router as is my Mac (though I have tried wireless). From the Mac I can see the PC fine in the finder. . I can open it up and see files, etc. Macbook Pro running El Capitan, PC running Win10.

I have also noticed in doesn’t give me the option of choosing a different library. . .just “looking for library” or the “setup” button.

On “Choose your library screen” there is a “Why can’t see my remote libraries” text, can you press on it and enter the IP address of your Core and see if the connection will happen?

@David_Grein are you still having this issue?

yes, still no luck.
When I enter the Mac’s IP address, nothing happens. (It goes back to the Choose Your Library page) and kepps on scanning.
Same as Adam. No problem connecting to the Mac Mini by finder or Splashtop.

Deleted Roon on the headless Mac Mini just now and installed Roon Server instead. Now it works! :slight_smile: