Roon on Mac Mini HDMI Output

(Bernd Kaponig) #1

Core Machine (Operating system/System info/Roon build number)

Mac OSX 10.14.6, Mac Mini 2018, Roon 1.6 (build 416)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Netgear Velops

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

HDMI to Meridian UHD722/G65

Description Of Issue

When I specify in the audio device setting “exclusive use” for my DisplayPort HDMI connection, Roon always outputs 6 channels, even if I set “2.0” for “channel layout”. This seems to be a bug. In addition, in this “exclusive” mode I can’t even override this in the Mac’s “Audio MIDI Setup”.

If I set it up NOT for “exclusive use” I can set the number of channels in Mac’s “Audio MIDI Setup”, but it is annoying that I have to change both the “MIDI” and the Roon setup to get things working.

(Noris) #3

Hi @Bernd_Kaponig,

Can I please ask you to share a few screenshots of this issue? Specifically, can you share a screenshot of your Device Setup tab that shows the 2.0 channel being set with exclusive mode on and then a screenshot of your Signal Path?

(Bernd Kaponig) #4

Here you are

(Noris) #5

Hi @Bernd_Kaponig,

Thanks for sharing those screenshots. I am next wondering what all available output options are for the Display port zone when there is 2 channel content playing. Can I please ask you to start playback of 2 channel content as you have done in the screenshots and then click on the “format” dropdown menu and share what you are seeing there?

(Bernd Kaponig) #6

I cannot change the format, Roon’s “exclusive mode” prevents that. Only if I turn exclusive mode off can I change the format. But I don’t want to do that manually, I want Roon to control it. And besides, I cannot change the format to hi-res, the maximum is 2ch 48kHz.

(Noris) #7

Hi @Bernd_Kaponig,

I am more-so asking a screenshot of the available format output options. If the format options only show up without exclusive mode enabled, can you turn off exclusive mode and provide a screenshot of what the drop down shows after you click on it?

(Bernd Kaponig) #8

The format options are ALWAYS there. However, if I select one when Roon has “exclusive mode” it doesn’t change but goes immediately back to what Roon set. But anyway, here’s your screenshot.

(Noris) #9

Hi @Bernd_Kaponig,

Thanks for sharing that screenshot, I believe I know what is going on here. As you can see in your original screenshot, you were playing 24-bit content to the Displayport zone. Since the Displayport output only supports 24-bit content as 6ch, this is why it was getting locked into 6ch instead of the expected 2ch:

My follow-up question for you, if you try to output 24-bit content via the TIDAL app instead of Roon and use the Displayport output, do you notice similar behavior in the Audio Midi tool? Note: Please try using MQA content in the TIDAL app with exclusive mode enabled as MQA content is 24-bits but the majority of TIDAL tracks are 16-bits. Exclusive mode can be enabled/disabled by clicking on (More Settings) next to the Displayport output in TIDAL Settings -> Streaming -> Sound Ouptut,

(Bernd Kaponig) #10

Same issue with TIDAL. No hi-res 2ch formats available in Audio MIDI Setup.

(John) #11

Hello @Bernd_Kaponig,

You could try limiting the device to a maximum of 16bit 48kHz playback in the “Device Setup” screen for the HDMI zone in Roon. This will cause Roon to automatically downsample and dither all audio to 16/44.1 or 16/48. This may allow for CoreAudio exclusive mode output to be in a two-channel format. We cannot guarantee this will work as we do not have the device to test with.

-John

(Kuryan Thomas) #12

This topic is interesting. I have a similar setup. I use a Mac mini as my Roon endpoint (not Core) and an HDMI cable to my Anthem AVM-60 pre-pro. The Anthem always shows “multi channel” as the input, but I only hear two channels and the stereo effect is indistinguishable from a 2-channel source like an Oppo 203 acting as a Roon endpoint.

I have a stereo power amp running my front speakers and a separate 5-channel power amp running the remainder of my 7.1 system. Whether I power on the 5-channel amp or not, I hear the same music through Roon with the Mac mini…2 channels.

I’m not reporting a problem of any kind, but if you would like me to debug anything or look into any settings I have in either Roon or the Anthem pre-pro, I’m happy to help out.

Added: I frequently play 24-bit music both from local files and streamed from TIDAL. Always just two channels of audio. I use exclusive mode.

(Bernd Kaponig) #13

It’s the same on every Mac, at least on my MacBook Pro and the Mac Mini. And it’s the same with every HDMI device I have. I think it is actually a MacOS issue and I have raised a bug report with Apple. But it would be great if you from Roon would test this on any kind of Mac with any kind of HDMI device as well.

And downsampling is certainly not an option. I WANT to play the hi-res stereo stuff!

(Bernd Kaponig) #14

I have an Oppo 203, too. And when I use it as a Roon endpoint everything works just fine. The Oppo sends a proper 2ch HDMI signal to my processor, a Meridian G65, while Roon on the Mac (as discussed) only gets a 6ch hi-res signal across to the G65. In your case, Thomas, this doesn’t seem to be an issue as your AVM-60 seems to treat the two the same. However, my G65 treats 6ch input as movie material and offers only 5.1 movie DSPs. Its music DSPs, however, sound MUCH better for 2ch material so I’d like to leverage that capability (without downsampling). But I can apply the 2ch DSPs only for input that is actually 2ch.

(Kuryan Thomas) #15

I see. I misunderstood you. I thought you were getting sound out of 6 speakers instead of just two. My mistake, sorry.