Roon only runs as administrator (windows 8.1)

I run Roon on a Windows laptop however the strange thing is that it will only start when you click “run as administrator” how can I run it ‘normally’? Thanks.

Under which user did you install Roon?

Hi @rtlgroen – thanks for your question. I think @rovinggecko is on the right track here.

Right now, Roon installs on Windows are per user meaning each Windows user can have their own install of Roon, but right now, they can’t be shared by multiple users of the same PC. There are a number of reasons we install this way, and @danny discussed them (and the possibility of changing this in the future) here.

This is not necessarily why you’re having issues here (and here), but it seems likely. We install in a way that guarantees the user has full control of the install directory, so admin privileges should only come into play if you’re trying to run as a different user than when you installed.

Let me know if any of this rings a bell, and if not, we can look further. Thanks!

Hi @mike, @rovinggecko,

Thanks for your response.
To give you an idea. I’m the only user ‘Rene’ of this Windows machine and I have a personal account on this machine and have admin privileges to install stuff. Roon was installed with my own account. That’s why I think it is strange I cannot start it … it seems to start, but doesn’t do anything, also no message, I need to explicitly say to Roon - run as admin to get it started.

I tried now to run the Roon installer again, but still same thing.

Hi @mike, @rovinggecko,

I found that Roon is installed in my default user directory:

My default user directory is
C:\Users\René Groen\AppData\Local\Roon\Application

However Roon installed also something in
C:\Users\René Groen\AppData\Local\Roon (= made itself a new directory) with cache and database

So i think as my name (= my default windows profile) contains special character it is incorrectly installed by Roon. It cannot cope with this characterset.

Idea, how to solve?

Ahh good find! The Roon install should definitely be in C:\Users\René Groen\AppData\Local\Roon\ .

Ok – hang tight René. I’m going to see if there’s an issue with our install process, and will follow up.

Yes good find indeed :wink: @mike,

It should indeed be definitely in C:\Users\René Groen\AppData\Local\Roon\

This will also explain why I have issues with Artwork (another issue i logged on the support site) -> Roon/Tidal Artwork is not showing correctly as it mixes up the http/Cache and Database+DB cache directories in two different places now…



In the interim, have you looked at the rights for the funky user directory?
Try giving your ’ ok name’ full rights to it…

I gave the other funky user directory full rights and it is starting now without using ‘run as administrator’ however the issue with the Artwork not being shown/updated remains exactly the same (see my other thread for that). As all the ldb files are in the other funky folder it seems it has troubles to identify it from the real application folder. Guess that will only be resolved as all config is in the real user folder.

Mmm, on the positive side you can now start it normally, but annoying that the artwork is still missing.
Guessing that the process that creates it uses the funky name and the one that uses it takes the real name.

Temporarily copy the ldb files over? It then won’t update, but if your collection is not too volatile it could tie you over until @mike comes up with a permanent fix.

Hey guys - @rtlgroen. We’ve reproduced the issue, and you’re right – when there’s an accent in your user name, we’re creating extra folders during the install.

So, two options for now:

  • Wait for a fix – I should have some feedback soon about when we’ll be able to fix this issue, but I would guess we’re still at least a week or two away from having a fix implemented, tested, and released to you.

  • Uninstall/delete your current install, remove the accent from your user name, and start with a fresh Roon install. This workaround should get you set for now, but obviously it’s up to you whether you want to change your Windows settings

Thanks again for the report and sorry for the trouble here!

I’ll wait for the fix. Thx.


Hi Mike,
You know when a fix will be available? Thanks,

Yes! The issue should be resolved, and the fix will go out very soon, with our 1.1 Release.

Appreciate your patience here @rtlgroen!