Roon player issues and awkwardness

I have Roon installed on my Windows10 PC and also on my iPhone 6+. The NUC with ROCK sits on my desk between the router and the PC, all connected via Ethernet cables. I’m on my 3rd day with Roon and still learning.

  1. On the PC, when I open Roon, it often says it can’t connect, even when I’m in the browser and looking at stuff on the internet. If I close it and open it again, it usually works. Sometimes I’ve had to unplug the PC Ethernet cable from the router and plug it in again.

  2. On the PC I open Roon. If I then minimize the window and bring it up again, the window is blank. No matter how long I wait, it doesn’t refresh. This is very consistent, not intermittent. It doesn’t matter whether I’ve just opened Roon or whether I’ve been using it awhile.

  3. “Overview” appears as an option on the PC but not on the iPhone. I thought I read somewhere that the interface was the same regardless of the device.

  4. Selecting an album on the iPhone is the pits. On the PC I can just choose Albums and then either scroll it over or hit a letter on the keyboard to get in the proximity of what I’m looking for. On the iPhone it appears that the only way to get to the middle of the Albums is to scroll there – through all 4000 albums from the start or from the end. Intuitively (I know, that will get me in trouble!), it would seem reasonable to expect that if I start with Albums and then do a search, that the result would be an Album. Instead it does a general search, usually ending up with a composer or composition. Yeah, I can play from there, but what if I want the whole album instead of just one composition from it? Out of luck.

  5. I selected a composition by Grieg this morning that had 4 movements, and added them to the queue. Roon put this into the queue in the track order 3, 4, 1, 2. I deleted all four tracks from the queue and tried again. Same result. The movements are numbered in the metadata, and also the file names have the track number as the initial characters. Is this a bug, or am I doing something wrong? When I select by Album, everything goes into the queue in the correct order. BTW, I selected by composition from the iPhone, but when I couldn’t get that to work, I chose the Album from the PC. Finding the Album on the iPhone would involve a long scroll.

I have almost the exact same topology as you, so I will attempt to answer some of your questions.

Sounds like either a bad cable or router/switch port. I’ve never had that problem.

I’ve had core running on a NUC w/ROCK and a Roon instance on a WIN10 PC to act as a control point. I’ve never experienced what you describe, so I’m thinking it isn’t Roon, per se. Sorry, that’s all I have on this one.

The interface on iPhone is limited. In fact, it sucks. Really need a tablet for best results.

Sounds like shuffle, those crossed arrows in the queue display, is selected. If arrows are blue then shuffle is on. One has to actively turn shuffle off. It won’t expire on its own.

I’ll flag @support, they’ll probably have more for you.

Thanks for your info. We’ll see what @support has to say.

  1. Blank. Is that a black screen or a white one?

Hi @Stephen_Vorenberg, here’s my take on your issues:

I would take a look at your router settings. I have seen IGMP Proxying/Snooping help with this behavior in the past. I would also make sure that your network is set up as per our Networking Guide.

This seems like a display driver issue. I would update your PC drivers to the newest versions to see if it helps. You can take a look at this thread for more info (Windows 10 : Blank (white screen) after maximising) and possibly try the 32-bit version of Roon to see if it helps.

Yes, the mobile version has limitations when compared to PC/Tablet versions. I would not expect to see the same screens. You can use search to find the album you wish to play as you mentioned. Searching limited to just albums and not doing a general search is more of a feature request than expected behavior.

Can you let me know the exact composition you tried with? I can take a look to see if it is reproducible. If these are local files, please also send them over to us, you can PM me a shared Dropbox or Google Drive link and I can ask QA to take a look.


White screen.

Wow you sure jumped in with both feet! Welcome aboard!

Just to be sure, you’re talking about the Roon client not connecting to the Core? This does sound like an intermittent networking problem, however I would also be sure all your firewalls have Roon enabled etc.

Very often solved with a video driver update.

Go to the page with the Now Playing queue, with the album cover and band name above the queue and a progress bar right above the queue – notice to the right of the bar, there are two arrows that cross. This is shuffle and toggles on and off. This may be causing your queue ordering issue.

I’ve been using Sonos for awhile and knew I was going to eventually hit a limit. I hit it much earlier than expected, which “forced” me to consider other options for playing my digital music. Sonos seemed to recommend Plex, but everything I read about it didn’t seem to indicate a very good experience among the users, and it didn’t seem very well adapted to classical music. I saw one recommendation for Roon in all that blah-blah and checked it out. I also talked to Sonos about it. It looked like the avenue to go, so yes, I jumped in with both feet!

Video driver! Who knew! I’ll give that a try. I haven’t updated that in quite a while.

My shuffle toggle has been white. When I click it, it goes to blue. I thought blue was the “on” setting. Perhaps it’s the other way around?

I updated the video driver on the PC, but it had no effect on the problem of the content disappearing in the Roon window after I minimize it. I can live with this problem, I suppose, it’s just a nuisance to remember not to minimize the window. If I accidentally minimize and want to look at something, I have to close Roon and open it again.

You shouldn’t have to live with this problem. It isn’t normal behavior and no one else experiences it.

Are you still having trouble with tracks playing out of order? Is it just that one album?

Blue means shuffle is active.
Do you have more than one endpoint?

I agree you shouldn’t have to live with it, but I also wish these driver issues were as uncommon as you’re implying. Unfortunately, there seem to be extremely poor drivers out there (mostly Intel) that make it impossible for Roon to refresh the UI properly.

I discussed the issue in more detail a few years back, but for now, it would be helpful to know your video card @Stephen_Vorenberg. We can’t fix Intel’s drivers, but we might be able to help you find one that works :slight_smile:

Can you open up Device Manager and take a screenshot of your “display adapter” section and driver version?

Like this:


(Screenshot instructions at the end of this post)


Here’s my Properties for the display adapter (indeed it is Intel):

I’m unlikely to change the video card. This is a closed-system Sony All-In-One with no simple way to open it up. It’s about 7 years old now and may be nearing time for a new PC. It has been getting increasingly flaky.

Now that I know about the NUC and how easy that was to assemble, I might consider going that way for a new PC.

BTW, I’m really loving this software! I’m not easy to please, but this greatly exceeds expectations. It is especially wonderful that it recognizes compositions and selects via them. I’ve been experimenting with Roon Radio this afternoon which also selects compositions. Nice!

@Stephen_Vorenberg Have you tried the 32 bit Roon client - this has been known to help where the Intel HD drivers have been an issue

Thanks. I’ll keep that in mind to try, depending on my level of frustration.