Windows 10 : Blank (white screen) after maximising


(Ronni Hostrup) #1

Hi,

Having bought Roon - I am not quite satisfied with the fact that I cant minimize roon - without my screen getting blank.

Can this be solved?

My laptop is an Lenovo with the Intel HD Graphics 4000 card.

Are there any settings - that will make it work?

I’m using Windows 10 64bit.


Windows 8.1 : Blank (white screen) after maximising
Windows 8.1 : Blank (white screen) after maximising
#2

Hi Ronni,

I’ve seen this before, on both my Lenovo and other devices with the Intel HD graphics card fitted. I’m my case my Lenovo also had an NVidia card fitted so I just configured my graphics driver so Roon would use that.

I recommend checking / updating so that your Lenovo graphics drivers are up to date and then re-test.


(Ronni Hostrup) #3

Hi Carl
Thanks for your reply.

My Laptop - only has an INTEL card - no other graphics.
and i updated the driver today - still no changes.

Its strange - cause i have used alot of programs on my machine - over the years. And i have never seen anything like this. Not Spotify nor Tidal or any others.

Are you aware of any third party gui’s?
maybe someone outside of roon has coded something?


(Rene Bouwmeester) #4

You may want to read this for more info:

https://community.roonlabs.com/t/roon-becomes-unresponsive-ghosted-out-completely/13683/10


(Ronni Hostrup) #5

OK.
So from what i can read - in other forums post - the only solution is to buy another computer - because my graphics cards are not supported.

Thats a shame - and i actually think that roon should have made this information available - eg. make a hardware tester that you could run before - to test if your system is compatible with roon software - before buying it.

Alternativly Roon should really consider -making a web-based interface for controlling the server - that would solve alot of issues.

unfortunatly my roon machine is also my work pc - so i guess i will have to wait until my company issues me new laptop - before i use it… shame really

br Ronni


(Daniel Beyer) #6

You obviously don’t play any graphical video games or you’d have encountered this problem all the time. The weakness of earlier Intel integrated graphics are why, as with Carl’s laptop, laptop manufacturers began putting 2 graphics systems into laptops.


#7

Hi again,
Roon do offer a no-risk 14 day trial period, so the full program can be used before one commits … maybe a GUI test tool would also helpful … one for @Brian to consider.

Going back to graphics drivers, did you check on the Intel site directly rather than relying on the Lenovo system tools?


(Mike) #8

Sorry for the frustration here @Ronni_Hostrup.

Just to be clear, this is a bug in certain drivers, not a hardware limitation. We’ve seen new drivers get released that resolve this for people, and we’ve seen people manually download drivers (as opposed to the automatic downloads that Windows does) that resolve the issue as well.

As @Carl mentioned, I would look into getting drivers directly from Intel to see if that helps here, and feel free to drop me a line if you’re feeling like Roon isn’t working as expected – we’ll do whatever we can to get this resolved to your satisfaction @Ronni_Hostrup.


(Rene Bouwmeester) #9

Regarding the hardware: I’ve been running Roon on Macs with Intel HD3000/4000/5000 and 6000 chipsets – all without problems. This truly is a (nasty) driver issue.


(Keith Lamont Davis) #11

Yes, I’m hoping for a fix for this too. Roon doesn’t play nicely with certain (widely used) graphic chipsets. I’ve never had this problem with other software.


(William Koch) #13

I am running Roon 1.2 Build 165 64 bit on a Win 10 Pro computer with an Intel i-5-3450 CPU @ 2.8GHz and 8.0 GB RAM. My music is stored on a WDMYCLOUDDL2100 NAS device and I play the music through either a PS Audio Directstream DAC, back to the computer, or on a couple of networked HiFiBerrys in the sunroom or the garage. My collection is over 1200 Albums, 700 artists and close to 18,000 tracks.

The specific issue or crash is that when I minimize Roon to the taskbar and then try and call it back, Roon displays a Blank white screen that still has some function, i.e. I can stop the music if I click in the right spot, the program continues to play music but can see nothing. I need to close out the program, which stops the music and restart to enable video functionality…a pain. So long as I don’t minimize the program to the taskbar I am ok The issue started prior to the recent update. I have been a member since October, 2016. So far Roon is the only program that behaves this way. Any help or suggestions would be appreciated. Thanks.


#14

Hi William_Koch,

I’ve merged your post into this topic, most likely this is a graphic driver issue. Can you check to see if your PC has the latest drivers loaded.

Have a read of this topic for more information …


(Mark) #15

Mike, I have same problem, also intel 4000 graphics card. never seen this with any other application. have updated driver to nov 16 driver, problem persists.


#16

There are 3 different sources for this driver. The PC / Laptop manufacturer website, Intel website or Microsoft Update.

Sometimes the most current driver does not necessarily means this would fix a particular issue, therefore using a older driver is a better way to go.

With regard to the Intel website there are 7 different versions of the driver.

Sometimes the manufacturer of the PC / Laptop also would have multiple versions of a driver.

When I installed Windows 10 on my machine I let Windows select it’s own default driver and then updated it from the Windows update.

M.D.


(Eric Stewart) #17

Hi @Mark_Sherman ----- Thank you for the feedback. Sorry for the troubles here, have you read through Mike’s post mentioned above?

Unfortunately, this issue that you are experiencing is symptom of a bad driver update. There is very little we can do in this scenario as the driver is not refreshing the screen properly.

-Eric


(Mark) #18

Sorry, but all of my other applications run perfectly, perhaps your choice of opengl is at the root of the problem. My other client on my Nexus 6p also has issues, so you are 0/2 with me despite now having over 100$ of my money. Seems that you are a well financed spin off of Meridian/Sonos, out to conquer the universe. To do so you should have client performance that is up to the measure of your parent company’s brand and not going 0/2 with your new customers. Sorry that’s a Windows driver issue is just not acceptable. You need to be providing stable clients that operate across all platforms to succeed. Why not just give us a html interface that will work on any machine?


(Danny Dulai) #19

I agree that this Intel driver situation stinks, and there are other technology decisions we could have made that might have let a 4.5 year old graphics chip work a bit better. But it is noteworthy that this is the second disastrous chip by Intel, the first was the Sandy Bridge HD 3000.

[quote=“Mark_Sherman, post:4, topic:16711”]
Sorry, but all of my other applications run perfectly[/quote]

This Intel driver is notoriously bad on WIndows. Here is an example of it failing on EXCEL. Yes, Microsoft Excel is screwing up on the Intel Driver: https://communities.intel.com/thread/20966

Roon pushes quite a bit of textures to the GPU – this pushes the Intel Driver pretty hard and causing it to mess up. We’ve seen this over and over with certain drivers, and not with others.

Unsure what other apps you are running, but Photoshop and Lightroom are also known to screw up on Windows with the Intel HD 3000 and 4000, both which push the GPU.

Most our team are actually Android fans, and the most popular phone we use is the Nexus 6p. Besides a problem with a unreleased developer preview build of Android 7.1.1, there have been no problems there. Also, even though we have worked around some of the issues on 7.1.1, it looks like many other developers are having issues with 7.1.1’s changes in the area of screen sizing. I hope they fix this for the planned release (maybe this week?), but it doesn’t look hopeful.

It sucks that you ran into 2 issues, one with old hardware and one with too new of software.

We are a self-boostrapped startup formed by a team that split out of Meridian, with no ownership, share, or influence by Meridian. Before Meridian, our exact team that created Sooloos, that Meridian acquired back in Dec 2008.

I think you meant to write Sooloos, and not Sonos, as we have nothing to do with Sonos. However, we ARE the Sooloos team. I personally invented the name Sooloos back in the late 1990s and it was my personal project that Enno took to market. The rest of the Roon team (minus a few new hires) that you see here worked on the Sooloos project post launch, and built Sooloos 2.x while at Meridian.

Sooloos was Direct3D based, meaning it only ran on Windows (the Control ran XP Embedded), which worked fine on that hardware, but it also used quite a few UI tricks that are no longer acceptable in 2016 (no smooth scrolling anywhere).

As for OpenGL – it’s the only performant option available across Android/iOS/MacOS/Windows.

HTML would fall over, especially on a machine with 4+ year old gear. We know this, because we did this experiment. The browser just doesn’t scale on memory consumption or performance when it comes to long lived applications that are graphically heavy. It’s getting better daily, but not for an app like Roon.

Most of Roon was developed on the Intel HD 4000 on a MacBookPro Retina (early 2013), as it was the machine of choice for 2 major developers. MacOS’s graphics drivers are known to be slower and more limited that the Windows equivalents, but they also doesn’t fail like the Windows drivers by Intel on these older chips. However, this chip CAN work. The Mac driver clearly demonstrates that. Note that the exact same OpenGL code runs on Windows and Mac, so it’s a great A/B test where the driver is the only relevant difference.

Agreed, but there is only so much we can do here… the real question is do we spend time finding workarounds for half-decade-old GPUs and their buggy drivers or work on future features? Please don’t be upset with us, it is Intel that has forsaken you. We have tens of thousands of members, and only a few handfuls of people have run into this chipset’s issues. It’s unfortunate, but we have to look forward, not backward, especially when some of those people did driver changes and got things working.

As for your Android 7.1.1 issue on the Nexus 6p, we addressed it pretty quickly, because we could – just awaiting release right now. This Intel issue has been plaguing us for years. It’s one of the reasons we offer a trial. This issue usually comes up pretty quickly if the machine with this configuration is your primary Roon machine.

We said Ivy Bridge+ in our hardware requirements back when we launched in early 2015. Although we do run on the earlier Sandy Bridge, it is unbearable due to these types of issues (there is another CPU pipeline / RAM bottlenecking issue with Sandy Bridge). Ivy Bridge is starting to feel that way now. @mike, maybe time to update that to Broadwell?


(Mark) #20

Danny, thank you for your detailed response. It is very appreciated and shows your passion for a great product. Yes, I meant Sooloos, not Sonos. If I didn’t appreciate the innovation of your platform…I wouldn’t have shared my frustration.

I’m a bit surprised that you characterized my graphics card as 4.5 years old, but I’ll take your word for it. It runs on my Thinkpad X1 which may in fact be more than 3 years old but still rocks and refuses to slow down…just not realistic for me to upgrade over this issue. I guess I have to make a choice whether to work around the white screen/openGL redraw issue. Hoping that the final build of Android 7.1.1, due any minute will resolve the sizing issue on my 6p and if not your next release.

I am enthusiastic about your system and considering a new tablet to sit in my media room specifically to run Roon. Any recco?


(Mike) #21

You said you updated the driver, how exactly? We’ve seen people get around these issues with a little trial and error, so I’m wondering if there’s a method you haven’t tried yet (ie, going via the Intel site vs going via the Lenovo site, manual driver update vs automatic, etc).

Most of our team runs Android phones, but I think it’s safe to say that general consensus is that iPads make the best tablet remotes. If you don’t need audio from the tablet in your media room, that would be my recommendation.


(Mark) #22

Mike, I keep my system up to date, so the problem presented itself against the latest drivers from Lenovo. Then after reading your forums I went to the Intel site and downloaded and installed their latest driver…issue persists. While there may be some older driver that is compatible, trial and error of the last 10 drivers is not what I’m up to. There seems to be limited configurability, switching antialiasing, etc. I’ve tried all that to no avail.