Roon playing tracks twice depending on which play button used [Ticket In]

Just playing via Qobuz the de Falla El Sombrero de Tres Picos in the recent version by Mahler Chamber Orchestra under Pablo Heras-Casado, the first tracks of each of the two parts get played twice. This seems to be because Roon has given headings to the two parts but associated the first track of each to the heading. This does not happen if one listens directly via Qobuz, so does seem to be a Roon issue.

Hi @Paul_Graber,

Can you confirm that this is the album in question?

And these are the affected tracks?

I just tried starting playback of the album (clicking the blue “Play Now” button next to artist name) and I am not seeing the first tracks of each part playing twice via this button.

Edit: For thoroughness I just tried using the play button next to “El Sombrero de tres picos, ballet in 2 parts, G. 54” and there I am able to reproduce this issue so this seems to be related to which button you start playback from.

I will file a ticket with the technical team so we can take a closer look at this behavior, thanks for the report!

So confirmed. Glad you could replicate!

1 Like

I’ve now had a similar experience with the Pappano recording of Massenet’s Werther. Start from the beginning and the Prelude gets played twice. I suspect there’s actually something amiss with the way that Roon is indexing Acts, Parts etc.

1 Like

I experience the same with tracks from my local library

1 Like

Hi @Klaus_Kammerer1,

Can you please provide the names of affected tracks and send me this media for analysis via private message? I’d like to attach it to the investigation ticket. Thanks!

Synology NAS, Mac Client, Roon ver 1.9 (build 511)

Album: Works of Igor Stravinsky
Disc: 2 (the problem is not limited to this particular Disc)

See screenshots below. I noticed that some tracks are played twice before advancing to the next track. At first I couldn’t figure out why. Then I looked at the Queue and understood. Usually when one clicks on the first track of the album or disc in the multi-disc album, that track and the rest of tracks in the album are copied into the queue.

In this case, as you can see, the first track is placed in the queue, followed by the multi-track group - 5 parts. That 5-part group also includes the first track, which makes the first track play twice. Same for other track groups. Roon copies the first track of the group, followed by the group itself, which includes the first track. Then result, the first track of each track group is played twice.

Here are the tracks:

And here is the corresponding queue:

Hi @xred,

Thank you for the additional report, we are aware of this behavior and have an active ticket pending review by the dev team.

I can Confirm the Issue described Above. It Happens everytime when I try to Start a larger Part (Act I, Act II, etc) within an Album. The First Track is always Played twice

Hello @Paul_Graber/@MRas/@xred,

We’ve recently released Roon 1.7 (Build 521) which includes changes that should improve this behavior. Please give it this a try and let us know how it goes!

You can read the full release notes here:

The Team at Roon Labs

Tried it today, looks good, and I like the solution. Essentially you put the entire multi-part set into the queue, and allow to show the comprising tracks via the pop-up. Very nice.

Thank you for the all the hard work! I love Roon.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.