Roon Radio Doesn't work on Tidal

My roon when i am trying to use radio mode pops up a message which says “Nothing similar to play”,
neither for my database or my Tidal account.

I am using roon from a desktop pc, I have a tidal account connected (the account worked fine, few days ago for roon radio).
I disable the tidal account from roon menu and after that the radio works just fine, also tidal for every other operation exept radio is working properly.

Also i tried to change my network DNS with the google one ( & with no result.

I am using the 1 month trial account of roon and i was thinking to proceed with an annual account which at the moment i will not…They just passed 20 days after i started using roon and the application already is not working properly…

Is there any available solution?

Hi @michalis_loupasakis,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Is there any change after rebooting your Core machine?

I have already read your appentix but i wasnt in position to find something that match with my case…so thats why i opened up the case here.
My main machine (which has the roon) is an i7 with 64gb or ram, 1tb ssd (for the operation system), 6tb hard drive (storage), windows 10 operation system and it is connected directly with a cat6 cable with my router (cisco).
I am running roon directly from the machine not from network (usually), also as i mentioned before radio worked properly few days ago.

Of course i restart the machine, i checked ips, tidal site, etc with no result
So any ideas?

Is there any available solution?

Hi @michalis_loupasakis,

I’d try a cache clear next to see if this helps:

  • Exit out of Roon
  • Find and open your Roon database
  • Navigate to Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon and verify if the issue still occurs

Can you give that a try?

Did it, nope nothing changed, the same issue!


Hi @michalis_loupasakis,

Thanks for trying the cache clear and sorry to hear it hasn’t helped.

I would like to take a look at logs to see if we can gather some more information, but before I go ahead and activate diagnostics mode on your account can you please try starting Roon Radio once more and let me know the exact local time + date + artist/track/album you attempt to start it off of?

Also, can you provide some more information regarding your network setup including model/manufacturer of your networking gear and how your PC is connected to the network (WiFi or Ethernet)?

25/3/2020 11:49 (UCT/GMT +2, Athens Greece) AC/DC, Back In Black, Hells Bells.

My pc is connected with ethernet up to a Speedport Entry 2i

So almost a week passed and no solution until now neither an update. Sorry but my trial account finish in a few days and i will not proceed with a purchase.


Hi @michalis_loupasakis,

Thanks for letting me know regarding the timestamp, I have activated diagnostics mode for your Core and what this action does is automatically upload a log-set to our servers for analysis. I can confirm that this report has been received and I am discussing it with QA. I will follow up with you via private message regarding the trial.

Thanks for your effort and your thought, i appreciated a lot.

1 Like

Hi @michalis_loupasakis,

I spoke to QA regrading this behavior and we would like to take a look at the “live logs” when it occurs. The window for us to access these live logs are a bit narrow, meaning it would be best to schedule a time that works for both of us and also when QA/the devs are also online (they operate in a different time-zone).

I will send you a private message with my proposed times and please just let me know which day/time works best for you. Thank you!

The technical support is checking the problem 8 days now without any feedback or a solution. Sorry but you lost me…i though you were the best…but…i was probably wrong

Hi @michalis_loupasakis,

I have followed up via private message.

Hi @michalis_loupasakis,

We’ve made an update to our servers that we believe will help improve this. Can you give this another try and let us know if things are working for you now?

Your patience as we’ve looked into this has been greatly appreciated — Thanks!

The Roon Support Team

To be honest with you after 2-3 weeks without a fix, i stopped using roon.
I just remember that the free trial expires and i came to see if you have fixed it or not.

Thanks for the efford better luck next time.
*For the record, i updated roon just from curiosity, yes the problem solved with the update.

Hi @michalis_loupasakis,

I have followed up via private message.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.