Roon Radio fails when started from a Genre [Resolved]

Core Machine (Operating system/System info/Roon build number)

Windows 10 Pro 2004, build 19041.330
Intel® Core™ i3-2100 CPU @ 3.10GHz, 3100 Mhz, 2 Core(s), 4 Logical Processor(s), 16GB RAM
Roon Server Version 1.7 build 571

Connected to both Tidal and Qobuz

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Spectrum 300Mbps -> Motorola MB7621 -> Netgear R7900P -> D-Link DGS-2024D -> Gigabit Ethernet,
Router WAN DNS configured to point to Google DNS

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Windows 10, version 2004, build 19041.329
Intel® Core™ i7-8700K CPU @ 3.70GHz, 3696 Mhz, 6 Core(s), 12 Logical Processor(s), 64 GB RAM
Roon Version 1.7 build 571

Description Of Issue

Roon Radio fails with “Unexpected Error: Limiting Roon Radio to library”
Tried to play Roon Radio for: various music genres, after music in queue ends, etc. it always fails with this error.


  • Playing music from library, Qobuz and Tidal works as expected
  • Browsing the library, Qobuz and Tidal works as expected

I’ve tried the following troubleshooting steps:

  • disable firewall on the server
  • change DNS to point to Google DNS (first on on router, then on server, flushed DNS, restarted server, etc.)
  • disconnect and then reconnect to Qobuz and Tidal

None of the above troubleshooting steps resolved the issue.
Please help.

Hi @cata,

Please accept the apologies for the trouble this morning. Our team confirmed that there was a brief service outage that affected Roon Radio playback which has since been resolved. Things should be working for you now but please let us know if you’re seeing otherwise.


Hi @dylan,
Thank you for the quick reply.

I can confirm that playing Roon Radio for an artists, album or track is working.

Alas, something must still be off: Now I get “Nothing similar found: Limiting Roon Radio to Library” when trying to play Roon Radio for a music genre or sub-genre. I’ve tried a number of genres and sub-genres, from classical to Chicago Blues and none work:



I am getting the same error


Ditto. Annoying. Take action.


This inscription appears all the time. Do something already!

1 Like

Hi everyone,

Thanks for letting us know, we are looking into this.

Also getting this error when attempting to start radio using genre.

Anything on this yet?

Anything on this yet…any suggestions on changes we could make on our end?

It happens on Genre and Sub Genre

1 Like

And what? The problem remained. Are you going to fix her or will you just watch?

@dylan, thank you for looking into the issue - based on the lack of updates, I gather this is a non-trivial fix.
Do you have a rough estimate as to how long it may take to address the issue (days/weeks/months)?


A post was split to a new topic: Trouble starting Radio from an album

I met with the team to check in on this and they’ve let me know that they’re still investigating this and we hope to have things resolved soon. We’ll be sure to keep you all updated as soon as we have more information. Thanks!

1 Like

I have the same issue, roon radio stopped working for genre

Why, when starting Radio by genre, it does not write enough matches and starts Radio limited by the library. Although noted in the media library a huge number of artists in the genre. Both Qobuz and Tidal are connected. And this applies to Pop / Rock, even R & B, which is simply a huge number.

same issue here from Genre…

Update on genre radio issue please?

Last update was was days ago. Any info on the genre radio issue?

1 Like