Roon Radio limited to library only


I also have the problem, that the radio is limited to my library. Nothing I do changes this… Settings are not set to library only. Qobuz by the way.

Hi @Marc_Haberberger,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Has this always occurred for you or is this a recent change? Have you tried rebooting your Core machine?

Hi @dylan

Thank you for your answer. I will describe the problem:

What is not working: Roon Radio is limited to my library. No matter if I set the filter to library only or not. If I play Radio from a song that is not in my library than no similar tracks are found and the radio stops.
How often occurs this: I have been testing Roon for a few days and it did never work for me.
My Setup: I run Roon on my MacBook Pro 15. My local library is on the SSD of this MacBook. Besides I am a Qobuz Studio subscriber. I stream my music to my Chord Mojo/Poly, Apple TV or iPhone 8 (newest iOS version). I think everything works fine, but not the radio. That function is one of the reasons I gave Roon another try. I have already tried the “fixes” above and also rebooted my MacBook. Nothing changed.

Thank you for your help.

Here a new screenshot

Hi @Marc_Haberberger,

Thanks for the info here! I’d like to propose a test that should give us some additional information.

  1. Do a search for The Beatles
  2. Open The Beatles artist page
  3. Navigate to a Qobuz version of the Sgt. Pepper’s Lonely Hearts Club Band album
  4. From this album, click the arrow next to Play Now and choose the Roon Radio option. Make a note of the time you choose this option

Does Roon Radio work as expected? If not, please include the time that you tried to start Radio in step 4 above along with your time zone. We can enable diagnostics on your account and take a look at what you’re experiencing here.


Hi @dylan,

I did everything as you said. The same error.
Time: 22:04 CEZ

Thank you and greetings,

Thanks @Marc_Haberberger!

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Thank you @dylan,

I listened to some music. So the diagnostics should be uploaded.

Try logging out and in to streaming services?

1 Like

It worked. Thank you very much!

Great! Happy to help. Especially Qobuz, I have noticed, looks logged in from Roon but doesn’t always respond. I noticed that when I switched cores over a weekend when I was at a different house.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.