Roon radio only limited in Library

Core Machine (Operating system/System info/Roon build number)

Roon ROCK 1.7 build 528 run on iMac Pro Catalina system

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

ROCK through home wifi network. All devices connected to home wifi.Roon connected to library on external hard drive and also logged into TIDAL and Qobuz.

Description Of Issue
My Roon radio is giving me an error: “unexpected error: limiting roon radio to library”. It was working properly until yesterday. I have researched this issue on this site and done the suggested fixes (restarted my router, restarted ROCK, disconnected and reconnected to TIDAL, also I have disabled Qobuz). I have also double checked to make sure the slider for “limit roon radio to library” is OFF.

Also per suggestion of a prior post, I searched for and started Roon Radio on The Beatles Abbey Road, but the same issue occurred. It stated “Roon Radio: Nothing similar to play!”
Not sure if a timestamp will be of use at this time if you haven’t turned on logging, but this occurred at 21:31 UK Time.

Thank you for your help.

Hi @Alex_Chu1

Do you see this

[music/mlradio] _GetNextItems Failed: System.Exception
failed to init swim: System.Exception

in your roon server logs? Maybe we have the same problem.

Hi Dawid_Kotlarz

I do have this in the server logs:

[music/mlradio] _GetNextItems Failed: System.Exception: /session/continue failed: 500

Hi @Alex_Chu1

It is probably the same problem as in Roon Radio issues with TIDAL enabled

Hi @Dawid_Kotlarz

Yes I think we have the same problem. I have tried all the suggested solutions but none of them worked. Roon radio won’t play music from Tidal or Qobuz.

A post was split to a new topic: Problem with Roon Radio since update with TIDAL

My Roon Radio back to normal now, I didn’t do anything differently…

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.