Roon Radio only plays songs in library

Core Machine (Operating system/System info/Roon build number)

Windows 10/Roon Version 1.7 (Build 528)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Netgear Nighthawk with Netgear modem, ethernet plugged into core and destination.
Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Bluesound Node or DragonFly Cobalt

Description Of Issue

I didn’t get into the weeds with the network information because when I had the trial Roon account, my Roon radio worked fine. I just got it for a year with a different account and it is working fine, except the radio. It will only play things that are in my library (whether it be local or Qobuz) but it will not give me something new, which sucks because I really liked that feature of it in the past. I just keep getting an unexpected error. I tried restarting my computer to see if that fixed the issue and it doesn’t seem to.

EDIT: It is worth nothing that if I play something that my library doesn’t have, then it doesn’t even come up with something next to play. Like I said, I’m not sure of the issue as when I had account 1 for two weeks, it worked fine.

Hi Brandon,

If you read through the thread below, I’m wondering if there is any commonality? I know you mention Qobuz and the rest of us are having issues with Roon Radio and Tidal, but if you see my reply in the thread, can you replicate the issue albeit with Roon Radio and Qobuz?


Yeah, that thread is the issue I am having. The only difference between when I had it working and now is different Qobuz/Roon account and I’m sure Roon has been updated since January. That’s it.

That’s interesting as it doesn’t involve Tidal. I made an initial assumption it was Tidal integration, ut as it is happening for you on Qobuz, then it points to something Roon-centric. I’m sure the guys will find this additional info useful - @dylan is all over @Dmitrii_Osherov’s other thread I linked to and working with the senior dev team.

It’s the @support team’s prerogative to work through the existing issues first, but if there is a solution on the other thread before they get to you, then you can follow the other thread too and get notified if anything happens there. T.


A post was split to a new topic: Roon Radio only plays songs from library

I happen to launch Roon and it is working all of a sudden. Not sure for how long but I am happy everything is working.

Mine started working too.

I noticed yesterday afternoon when I was doing some testing to see if the Tidal non-lookup happened on either my laptop or any of my Sonos boxes as opposed to the Bluesound. It worked on the others, so I tried the Bluesound again and it was working there.

It’s making life hard to aid in diagnosis when the behaviour is not consistent. I had an inkling that maybe it was because Tidal had been in use on another platform (phone or through Sonos app) and hadn’t gracefully ended that session and was therefore cattling something in the Roon-to-Tidal world - have just tried to replicate that scenario and seems it was a dead-end.

Clueless as to why this is now working…

Hi @ElTel and @Brandon_Weiss,

Thanks for the updates here. Our team is still looking into this, so if you do see this behavior return please let us know!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.