Roon Radio - skips through tracks without playing

Maybe something similar to Roon Radio stops playing. My current config:
Ubuntu server running Rooncore
Roonendpoint: Bryston BDP-3, via USB output to DAC
DAC: Bryston BDA-3

Resync delay: 500ms

Any suggestions?

1 Like

Hi @Ian_Drachman,

I have a few questions starting off:

  • Does this issue occur just on the Bryston zone or are other zones affected by this as well?
  • How exactly does it skip through the tracks, is there an error message displayed?
  • Have you tried rebooting your Core + Networking gear yet? I would give that a try
  • Are you able to play back local tracks?
  • Are you able to play streaming tracks (TIDAL/Qobuz)?


Hi @noris,
It only affects this one zone - i tried on a google mini and no issue
Skips through tracks, no error message displayed
increased delay to 1000ms and no change in behavior
I stopped and restarted the service on Ubuntu and no difference. I will try a reboot tonight.
radio - qobuz or tidal or local, i leave it up to radio what to play. If I don’t use radio, this skipping issue reveals itself when there is a change in resolution between songs. Its happened to me multiple times. Is there a log you wish me to upload?


Try unplugging each component for a few minutes (a cold reboot).

I had the exact same problem with a ultraRendu and my Emotiva XMC-1 (using its DAC). Rebooting everything resolved the problem.

Hello @Ian_Drachman,

I would try Dan’s suggestion of a full reboot but if things are still not working as expected afterwards, can you please note the exact local time (e.g. 1:44PM) when this issue occurs again? I can then enable diagnostics mode for your account and take a look around that timestamp to see if there are any clues for the cause.

I am also wondering if this issue could be related to XMOS so I propose another test here. First reproduce the issue and note the timestamp as I suggested above, and then after you are able to reproduce, can you right click the Bryston zone in the bottom right-hand corner -> DSP -> Sample Rate Conversion -> Enable -> Set Sample Rate Conversion settings to “Max PCM Rate”. After making this change please let me know if you are able to reproduce afterwards.


I did reboot the BDP3 and turned off and on the BDA3. No change. I will do a hard reboot of the roon server and then try again and then if fails do you suggestion above. I will try to record when this event happens.

1 Like

ran the test after a cold reboot. Roon radio ran for about an hour and then stopped, from 11PMET - 12AM ET, based on the history shown.
Turned on DSP and MAX PCM was already selected.
With the XMOS/DSP set to MAX PCM, it failed again after 1 hour, at 9:36AM ET today.
Re-ran test with Bluesound end point, no issue, didn’t fail even after 2 hours.
What’s next?

Same problems here @support

I also have Bryston BDP-3/BDA-3 combo.

Radio, shuffle and sample rate changes cause the BDP-3 to lock up and become unresponsive until it’s powered down and restarted. Normal playing of albums works perfectly at all resolutions of PCM and DSD.

My system is Roon server on a headless 2018 Mac Mini, hardwired with Netgear switch to Synology NAS and Bryston BDP-3.

This was an issue for me all along, until the one prior revision, which fixed the problem for the last few months. Yay. However, the most recent revision has borked it again.

good to hear I am not the only one with this equipment combo :slight_smile: and unfortunately the issue. Even upsampling to a consistent output at MAX PCM (384) didn’t work. We’ll see where the analysis takes us. @noris, what’s next?

Hi @Ian_Drachman,

Thanks for letting me know those timestamps. Hmm, I am seeing an issue that indicates too many items have been added to the BDP play queue. Can you please try clearing out your play queue by pressing this button twice (Clear Upcoming -> Clear All) and let me know if that changes anything?

@John_Toles - Can you please run the test I asked Ian to perform regarding setting the “Max PCM Rate” in DSP setup to see if that changes anything for you?


I have tried that setting too, without success.

Since clearing the queue, the issue has not reoccurred. What happened and how/ what needs to be done to permanently fix?

Hi @Ian_Drachman,

Glad to hear that clearing the queue has resolved the issue! I’m going to discuss with the hardware team for the possible causes why the queue could cause such behavior and will get back to you and if this was a one time change needed. I will get back to you after I discuss with them.

@John_Toles - Can you please give the same solution a try and let me know if it helps your case as well?


Clearing the queue lets Radio start playing, but at the next song or if you skip forward, it locks up the BDP-3 and Roon starts scrolling quickly through one song after another without playing anything until I reboot the BDP-3 to stop Roon from trying to send songs.

BTW. I’ve been streaming to my Apple TV 4K all day with Radio and Shuffle without any issues.

Thanks @noris and @John_Toles . I didn’t test skipping forward to see if it behaves properly. Since this issue hasn’t existed with Bluesound, Google mini speaker, Apple, etc. what’s unique about the Bryston BDP-3? Its running as a LInux appliance, is there some threshold/configuration within it that can be a cause/contributor? Chris from Bryston is aware of this issue as I posted it on their support forum too.
Update: playback stopped at about 715pm last night. Lasted much longer though before stopping.

John, i’m on BDP-3 version S2.39 2019-01-16, which is the beta version. from the update-firmware section url should be extended with “#beta” after firmware.php.

@noris, hi any Update?

Hello @Ian_Drachman,

We are looking into the issue with our Roon Ready and Roon Tested in-house hardware.

Can you tell us if you are using the USB 2.0 or USB 3.0 connections on the back of the BDP-3 to connect to the BDA-3?


@john, i’m using USB 2.0. Since I’m not at the unit (BDP3) now, I verified by looking at the roon setting by clicking on Advanced. Do I also need to tell you which bus my USB is hooked up to? There are two choices. I can verify when I look at the back of the unit tonight or tomorrow morning. My USB cable is hooked into the USB 2.0 port on a separate bus than the other ports.
Its is not using the USB 3.0 ports.
Thanks for the update.


Update 2: this may be related, the problem of switching resolutions without first stopping play still causes a pop to be heard and playing stops. The BDP3 has to be rebooted.
Even with Resync delay set to 500ms or 1000ms.

@john, any progress or success diagnosing?