Roon Radio stopped working

Core Machine (Operating system/System info/Roon build number)
Problem experienced on two different Core-Machines:

  • Main Roon Server: Silent Angel Rhein Z1, current Software, Roon Build 528
  • For testing: iMac Pro running macOS 10.15.3, Roon Build 528

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Both Cores are attached to a FritzBox 7590 Router by LAN cable

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
Hi there!
I am currently using a Roon test licence, but I am definitely going to buy, when the test period expires. There is just one thing, that puzzles me:

When I started my test period, Roon Radio worked as advertised. But since a few days, I am getting error messages, that there was an “unexpected error” and "Roon Radio will be limited to the local library. It could not find any music via Qobuz.

There was a similar thread here, but it did not provide a solution for me:

In the meantime, Roon Radio even does not work with my local library anymore. Please see the attached screenshot.

The same problem applies to the two servers mentioned above. Restarting does not help.

Both Cores are attached to a FritzBox 7590 Router by LAN cable. I am currently using the following devices. See Screenshot:

Hello @Frank_Borowski,

Welcome to the forum!

What kind of streaming services do you have enabled in Roon? Both TIDAL and Qobuz?

Can you please try logging out of any streaming services and back in to see if it helps with this behavior? You can do this in the Roon Settings -> Services tab.

Hi noris.

Thanks for your reply.
I am only using qobuz for online streaming.

I tried to log out from qobuz and back in, as you said. It didn’t help.

It does only work, when playing a track from my own library, although Roon Radio says, it is limited to my library.

Hi @Frank_Borowski,

Thanks for confirming the Qobuz login refresh hasn’t changed anything. As for next steps can you please reproduce this issue once more and let me know the exact local time + date + track you experience it (e.g. 1:08PM on 3/18/20 when starting radio off of Artist XYZ).

A post was split to a new topic: Roon Radio issues with TIDAL enabled


It doesn’t matter which track is being played. But here are two screenshots with a timestamp in the file name from this morning:

In the first screen you van see that Radio is looking for Music, but then the “unexpected error” message appears. Just a second after that, a second message pops up, saying, that Roon can’t play any similar (screenshot 2).

Hi @Frank_Borowski,

Thanks for letting me know the track. I have enabled diagnostics mode on your Silent Angel Rhein Z1 Core and what this action should do is automatically upload a log set to our server for analysis next time it’s online.

While diagnostics arrive to our servers and we get these analyzed, can you please confirm if you have the latest firmware on your router? We have seen some issues in the past with older Fritzbox firmware so it’s worth a check.


My core is now online and I am playing a track (“Mood 4 Eva”, Beyonce etc.)

Interestingly, today Roon Radio works within qobuz! At least so far. I will observe that for the rest of the day.

Hi @Frank_Borowski,

Thanks for letting me know that Radio is working again. Is it still working properly even today?
I checked the logs and it looks like it could have been a temporary networking issue.

Hi noris.
Thanks for checking back.
Until now, Radio is working. It must have been a network problem between roon and qobuz. If it happens again, I will let you know.

Thanks so far! :slight_smile:

1 Like

Hi @Frank_Borowski,

That’s great news! Do let me know if any issues return, but hopefully they won’t.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.