Roon Radio: Unexpected Error limiting radio to library

Working again for me.

.sjb

Unexpected error - limiting radio to library. Back again this evening

Hi Ernie,

I noticed it too, but just got it to work. Try again.

Cheers, Greg

1 Like

Yes I have been getting the same error intermittently for a few hours this evening too. It is not just the radio for me either. There are times when neither files from Tidal nor Qobus will play when I hit play. The play head just stays in the same spot and refuses to move. i have had them play and stop in the middle too a couple times.

Locally stored files play all the through, once they start playing though. Still monitoring the issue.

That code seems to have come back as of this morning: ‘Unexpected error: limiting Roon Radio to library’.

Anyone else?

Yep, started playing up again.

Let’s flag @support here and see if they have any news.

Yes, this has happened again for me today.

We really do need an automated service status page so we can see at a glance whether it is a server or local problem, and what Roon are doing about it.

2 Likes

@support -

Last night I seeded Radio with Who’s “Magic Bus” and settled back for some nostalgia.

After about an hour, every track would quit after playing for a minute or so. I didn’t have a Remote handy so I don’t know what messages were being put out.

I had 3 zones grouped, but I was only listening in one, so I un-grouped them.

The next message I got on the Remote was something to the effect that an unexpected error had occurred and Radio would be limited to my library.

Looks like a Tidal problem, except that the tracks that Radio picked were Tidal tracks albeit tracks in my library. They played without any further problem.

All my endpoints and my Core, which is ROCK on an i5, are Ethernet. The endpoint I ended up with doesn’t use DSP. although the ones I un-grouped do.

If you want I can try to recreate this, but I’ll need to be pointed to how to upload logs, or whatever.

Hi everyone,

Apologies for the trouble here! Things appear to be okay on our end — are things working for you now?

Yep, thank you :slight_smile:

THere’s another report here Roon Radio limited to library, not using Qobuz + another user Roberto on French HiFi forum http://forum-hifi.fr/thread-130-post-229651.html#pid229651

So it doesn’t look fixed.

A post was split to a new topic: Problem starting Roon Radio

Same here I get the error :frowning:

Hi @Michael_Hurry,

Apologies for the trouble here! We resolved an issue and things are looking good on our end now. Are you still experiencing this issue or are things okay now?

Hi,
I was getting that error earlier today, but I just tried it again, switching roon off and on a few times and have not had the error.
Maybe its fixed itself :slight_smile:

1 Like

@dylan @mike Guys this seems to be a more common response since 1.6 dropped (imho) where roon servers seems to be having many many more issues…maybe this whole cloud based stuff doesn’t have a silver lining after all.

I hope things will improve for all and that maybe there is going to be some better monitoring and alerting system in the Roon infrastructure that will nip these issues in the bud before people have to start posting about them.

A post was split to a new topic: Roon Radio Playback Issue