Problem starting Roon Radio

Same issue here using Qobuz and ROCK. ROCK reboot and Roon restart doesn’t help either. I’ve also tried toggling the limit switch in the Queue section. Any luck getting this fixed?

Hi @BWQ — Things seem to be okay on our end, so I’d like to get a little more info about your setup and what you’re experiencing so we can get you up and running with Roon Radio.

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Is this only happening when playing Qobuz content? If you start Roon Radio from local content do things work okay for you?

Hi @dylan thank you for getting back to me.

My current setup is as follows:

  • Running Roon ROCK on a NUC
  • The ROCK NUC resides in my network closet plugged directly into a Unifi switch. The switch receives WAN access from my gateway.
  • Network chain from ROCK is ROCK>Switch> Unifi Wireless Access Point> Apple Airport Express > Lindemann Bridge
  • Audio devices are Lindemann Bridge> Sugden DAC>Sugden Amp
  • Local library files are stored in ROCK storage. I use Qobuz for streaming.

This issue happens when playing both Qobuz content and local content. After playing the last song in the queue, Roon will attempt to play the first track from it’s radio queue. I will then be presented with a message stating “Radio limited to local library” and it will never play Qobuz tracks that are not in my library.

I will add that I have tried toggling the switch in the queue that states “Limit Roon Radio to Library” and rebooting ROCK with no success.

Thanks in advance for any help.

Hi @BWQ,

Thanks for the details here! Moving forward with troubleshooting, I’d like to propose a test that should give us some additional information here about where this is stemming from.

Can you try to start radio while playing back to a different endpoint, like System Output of one of your remote devices? Does the same behavior occur when doing so?

Hi @dylan – test ran.

In addition to the Lindemann Bridge, I tried playing both to my iPhone and Macbook with similar results for both.

When I try to initiate the radio ending the queue with a local file, I am presented again with “Radio limited to local library.” However, when initiating the radio from a Qobuz track, I am presented with “Nothing similar to play” once the radio tries to start – which is nearly impossible as I tried with a number of popular tracks.


hi @dylan,

I am experiencing the same issues. Roon Radio is limited to library. My only streaming service is Qobuz. Playback of Qobuz streams is working without any problems.

I logged out from Qobuz and logged in again. Made no difference. After that I reboot Roon Core. In my Roon Remote I saw an “unexpected error” message popping up. Roon Radio is still limited to my local library.

I am running Roon Core on Intel NUC with Ubuntu. Playback devices are mainly my Linn Akurate Streamer and my Windows PC with an external soundcard.

Any help is highly apprechiated.

@papa.jay thanks for sharing. It sounds like we have similar setups (Qobuz, ROCK, NUC) and are experiencing the exact same issue.

@dylan I also initially received the “unexpected error” before radio was limited to library. It only showed once though the first time the issue appeared.

I found this post earlier today:

I did exaclty the same thing. I entered the Qobuz menu. After that I “restarted” Roon Radio by ending it and letting it make a suggestion after the last song in the queue.

From that point on Roon Radio was playing tracks from Qobuz again which are not in my library.

Tried this and it works until I play a Qobuz track that’s in my library. Then I receive the unexpected error message again and the radio is then limited to my library. If I log out and back into Qobuz again the radio again works but it’s a temporary work-around as it eventually presents an error again. Not sure if you have the same experience.

FYI @dylan

Hi @BWQ,

Thanks for the additional info.

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, your timezone, what track you were trying to start Radio from, and I’ll make sure we review the diagnostics related to that timestamp.

2 posts were split to a new topic: Problems starting Roon Radio

Thanks @dylan. Of course since “resetting” again I can’t get the error to reproduce. The next time it happens I will record the time and track (With location) and respond to this thread with it.

1 Like

A post was split to a new topic: Roon Radio limited to library only

@dylan it just happened at approximately 10:03am GMT (give or take a couple of minutes) after playing a Qobuz track. The track was Sonic Armada by Air on their album “La Voyage Dans La Lune.” It is the 24bit version with product code 3663729030504. Hope this helps.

Once this track was ending I received the error and the radio is now limited to my local library.

Hi @BWQ,

Does this occur every time you start Roon Radio from this track? What if you start it from the album instead of the track? Is Roon Radio doing this regardless of where you start it now or just for this one instance?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.