Roon Ready Won't Operate with Devialet Expert Pro [Resolved]

Core Machine (Operating system/System info/Roon build number)

Windows 10 Intel i3 PC - Roon 1.7 build 610

Virgin Hub 3 - Ethernet cables connected to PC and Devialet Expert Pro 220

I have just moved home and am setting things up again. For some reason, Roon Ready appears for a few seconds in Audio then disappears. Even when it is visible and enabled, it won’t operate.

I cannot get Roon to operate via Devialet Air at present either, though that would be academic if Roon Ready was working. I have tried disabling Air and that makes no difference for Roon Ready.

I would make sure the windows firewall settings are off while troubleshooting - if it works then, consider removing and re-adding the roon and raat applications to the exclusions again.

1 Like

Hi @PFBTG, to expand on @wizardofoz’s suggestion:

Since you are using a Windows PC, I would verify that both Roon.exe and RAATServer.exe have been added as exceptions to your Windows firewall.

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path.

I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have and ensure that you connected to your network via a Private network, not a Public one, see this guide for more information.

Thanks for the advice so far.

I have tried every variation on these themes and get no more than 20 seconds of music from Roon Ready consecutively. Any other ideas?

If it is relevant, the other Roon options have also disappeared from Audio settings.


Can you please use these instructions to send me a copy of your Roon logs?

I had the same issue sometime in the past. In my case, the cause was wrong configuration for some network devices. Are you using static IPs on Roon and / or Devialet, or maybe on other network devices?

All IPs are automatic, as far as I know and I haven’t ever changed any.

@PFBTG - According to logs, this looks like a networking issue:

09/04 19:36:39 Warn: [Devialet Expert 220 Pro @] [raatclient] RAAT Session timed out during initialization
09/04 19:36:39 Trace: [raat] [Devialet Expert 220 Pro @] => ConnectionFailed

I would check your firewalls on the router / Core. If you have another router, might help as well as we have often seen poor performance from ISP-provided networking gear.

You can also try a reinstall of Roon by using these instructions:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder

I assume the idea was to restore the database? I have and also done my best to check all firewalls on PC and router. I can’t see any issues or blocks.

Unfortunately, the problem is still there i.e. Roon Ready briefly appears then goes again.


The goal of this test was to see if a fresh database also exhibits this issue.
If you try to set up the fresh database without restoring, do you see the same issue?
If so, that would further point to the network setup.

Thanks. I will try that tomorrow.

PFBTG, in your Devialet configuration, do you have both WiFi and Ethernet configured and enabled?

I do in the Devialet configuration but as part of this exercise tried turning off WiFi on my PC, which made no difference.

That was a configuration problem I ran into, apparently you can only use one, so thats one item down, next using your Devialet Remote, long pause on the bottom right button to display your config on your Devialet display. Your remote may be different, but mine is the bottom right button. Scroll through and it will give you your IP addr and NIC addr, make sure no wifi address is there and a valid ethernet address is there and connected.

After that goto your router and in advanced settings check to see if that address is being blocked.

I missread your response, you should try Disabling WiFi in your Devialet Config, it should be one of the other, pick one, and re-try.


geoB. I think that is the solution. Having reconfigured Devialet to take out WiFi, the connection is better. There have been a lot of dropouts but that could have been an internet issue.

Thanks for your invaluable help to sort out this headache

1 Like


It looks as if the prob;em has been fixed, as you can see. Thanks very much for your efforts.

1 Like

10 posts were split to a new topic: Devialet 220 Discussion

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.