Roon Remote cannot connect to core following QNAP 4.4.2 update

QNAP TS-451+ , 8TB (4.2 TB available), QTS, Intel Celeron 2.0GHz 4 core, 8GB RAM

Roon Server Status : Running
Version : 1.7 (build 536) stable
QPKG-Version : 2019-06-09
Process ID : 18846

Installed on DREVO 250GB SSD connected to rear USB port
APC UPS backup

QNAP NAS is connected to a TP Link TL-SG1016D 16 port unmanaged switch via LAN 1
Router: Huawei B525s-23a

Play back clients:

Linn Majik DSM, Ethernet
2 x Raspberry Pi running PiCorePlayer, Ethernet
Apple Mac Mini, Intel i5 4GB, 10.4.6 Mojave, Ethernet
Apple Macbook Pro, Intel i5, 8GB, 10.4.6 Mojave, Ethernet
Cambridge Audio Edge NQ, Ethernet
Cambridge Audio 851N, Ethernet


Apple Mac Mini, Intel i5 4GB, 10.4.6 Mojave
Apple Macbook Pro, Intel i5, 8GB, 10.4.6 Mojave
Samsung Tab S5e, Android 9 kernel 4.9.112-16982790
Motorola X-Play, Android 7.1.1
Lenovo Ideapad 320s, Windows 10
Samsung Tab S2, Android
Xiaomi Mix 2, Android 7.0

Roon Remote on every device unable to connect to Roon Core following update on QNAP to QTS

prior to update, the system was working flawlessly. Did notice following update the QNAP renamed the USB SSD volume where the Roon Server was located, so on initial startup it showed as stopped and there was no storage data showing. Pointed Roon Server to updated location and Server restarted normally, however, no control point can connect to core. Have also noticed audio devices are now disabled on QNAP nas, previously they were enabled. Cannot identify how to switch these back on or if this is really necessary. There are no options in general settings - or anywhere else that i can find.

I have re-started all control devices running Roon remote with no change and they are all up to date.

I haven’t re-installed Roon server as i think the problem lies with either access permissions or Ports - but don’t know what has changed.

I work for Cambridge Audio and provide product and customer support so need Roon as much for this as I do for my own listening.

Please help!!

Should add that i use MinimServer on my NAS and other control software like Bubble UPnP,StreamMagic and Linn Kazoo function normally following the update. they see the server and music playback works as expected on the Cambridge and Linn Devices. (PiCorePlayer isn’t compatible so can’t use these at all)

I think you need to turn on the MultiMedia Service it’s probably disabled. Open the Multimedia Console from the Home Screen if there’s a shortcut there, if not open/enable it in Apps. See the attached screenshot, enable the toggle switch in the top right corner. Hope this works okay for you.

Hi. thanks for such a fast reply. Originally, this was enabled but I turned it off because it used so many resources: it took days to index my media library, was constantly updating apps i never use and using memory that I couldn’t spare. Roon functioned perfectly without it and local audio devices were still showing as active. i will enable it again and see what happens…

I thought that was a global setting for Multimedia Services. I wasn’t aware that the system was running okay with this disabled, maybe there’s more to your problem? You can turn off thumbnail generation etc in the Multimedia Console to save it using a lot of resources, have a dig around. I’ll be interested to hear how you get on.

Your suggestion has allowed Roon to get access to the audio hardware on the NAS…but, my main problem persists. Nothing will connect to the Roon core. Any other ideas?

Stupid question maybe but have you tried rebooting any of your hardware, switches, devices, router since you enabled Multimedia Services?

@support, @crieke Chris could you help with this?

Hi @Graham_Knowles
Could this be the issue:


Hi. I have re-started the NAS since i enabled Multimedia services and re-started multiple remote devices. unfortunately there has been no change. The core remains ‘invisible’ to the remotes.
Roon last updated a few days ago i think and it functioned fine. only following the QTS update last night has this problem been present. not getting any help from QNAP yet so was hoping you guys could shed some light on it.

Just to let you know. I am running Roon on a QNAP TS-473 and running the latest version of Roon Build 536 and everything is running fine. I know this may not help but it does let you know that Roon will operate with the latest QNAP firmware. Hopefully support will help.

Ok. This is strange. none of my Roon remote devices see my currently configured core but, if select change server in Roon remote, my currently configured core is presented as the only selectable option. if i choose this, it prompts me to login or try Roon as if i have never used it before.
So, i enter my roon account credentials and it then asks me to choose my library location, again, as if i have never used Roon before. i skip this for now, then it prompts me to enable all my devices (currently all disabled) and having done this, it works again (only i have no library). currently re-installing a back up from yesterday - hopefully this works)…

in summary, the QTS update seems to have erased whatever information is used for the Roon remotes to recognise my fully configured default roon server. The only thing that seemed to change was the SSD disk name which i had already noted.

i will confirm all is working again once the backup is completed.

thanks for your help guys.

Update: Backup completed but got an error message then saying that there was a connection failure. Was just about to throw everything out the window, when it changed it’s mind and said instead the database needed an update to work with the new version of Roon. it has completed the database update and hey presto…it works (on my Mac at any rate) I have tried my Samsung Tablet and this was the same. i had to select the ‘new’ old core and after a few seconds, everything was back to normal.

it seems likely the problem was caused by both Roon and QTS updating one after the other, without Roon first updating the library.

Perhaps this thread will help a few others avoid this aggravating issue!

Good news indeed, nothing more frustrating than software when it goes wrong but at least you persevered and got there in the end!

Glad you’ve got things sorted.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.