Roon Remote Connection Failed / Connecting [Solved]

Hi, everything was working properly until I swapped out the router for a Netgear ORBI router (which is incredible, btw, no more dead zones in the house).

Roon Core v1.2 (build 168) is working fine on Windows 10 64-bit and I’m able to browse and play music locally.

Roon Remotes, however, won’t connect over wifi. Remotes see Core, but the message on iOS cycles between “Connecting…” and “Connection Failed” every few seconds.

All devices are on the same subnet (10.0.0.x). Accept connections from remotes is enabled. Firewall on Core and Remotes is disabled.

Port forwarding has even been setup (UDP port 9003; TCP ports 9100-9200).

Remote apps and Core have been re-installed. Same issue persists.

Maybe your port forwarding is messed up…I don’t think there is any need to use port forwarding.

Even with port forwarding removed, the issue persists. Tested from Remote app on iOS 10.2, as well as Remote app on macOS Sierra.

Problem solved.

After switching routers, and in particular with the Orbi, it detected the modem subnet (192.168.1.x) and automatically set itself to a different subnet (10.0.0.x) to avoid conflicts.

On the PC, this in turn resulted in what was previously identified by the firewall as a private network becoming a public network. On the public network, Roon is blocked by the firewall. In my testing I’d only disabled the private network firewall, not realizing it was the public network firewall that was now in play.

Changing the newly defined network to a private network solved the problem. Hope this helps someone else in the future…


It just helped me! Thanks!

Thank you.
I encountered the same situation when I upgraded to the Orbi (which I agree is a fantastic router).

Thank you - helped me today when moving my core from Mac to PC.