Roon Remote Crashing (iOS) [Resolved]

Good evening @support

I would love some help with a problem. I am using the Roon remote on my iphone 8 (updated to latest OS) and for the past few days I am experiencing crashes. Roon keeps working (music continues), the core on my MacBook Pro is working as normal and everything is updated to the latest version.

The end points are as follows:

  • Roon Bridge on Mini PC (Win 10)
  • Roon Bridge on PC (Win 10)
  • Roon Core on MacBook Pro (High Sierra)
  • Sonos One
  • Sonos Play 1

The crash seems to happen for no reason. Once it does crash I try to double tap the home button and strangely I can see the Remote app in the background. It is almost as if it is still running but once I select it I see a black screen momentarily and then I am thrown at the iphone home screen.

I have tried uninstalling the Roon remote app and then re-install. This seems to fix it for a day but it will eventually crash again.

Any help with the issue?

Many thanks

Thanks for the report and feedback @Yiannis_Kouropalatis. We can certainly take a look into this behavior for you.

Moving forward, I would like ask you for some further insight into the “crash” you are experiencing on the iPhone 8. When the issue occurs are you losing connection with the core at any point or does the application just seem to close on the device? Can you think of any steps that you may be noticing that trigger this behavior? Is the phone going to sleep before this happens? Are you using other applications at the time of the crash?


Hi @Eric,

Thanks for getting back to me. I can confirm the Core continues operating without problems. Namely, I can use my PC (remote mode) to play music. The PC runs roon as a remote and communicates with the Core on my Macbook Pro without problems. The problem is only on the iOS remote app.

I can also confirm that when the crash occurs, music playback is unaffected. No dropouts at all.

The problems began roughly after I introduced two sonos speakers in my home: Sonos Play 1 and the Sonos One. I have tried restarting / rebooting my router, restaring the core etc.

Today I am experimenting with removing the sonos components (powered down) and running Roon as it was before. I want to see if the crash will happen again. if so then that rules out the Sonos being somehow contributing to the issue.

Regarding other apps, I am indeed using spotify on my iphone as well as the sonos app. I am not sure if this is related to the problem.


Thanks for the updated @Yiannis_Kouropalatis! Please let me know the results of the mentioned test(s) and we can go from there :microscope:


Hi @Eric,

Just a quick update on the crashing issue. I can confirm that it is not related to Sonos. I have deactivated (unplugged) the sonos devices and for the past few days used only 2 roon bridge zones. The roon remote app worked for 2-3 days and yesterday night it crashed. Just before it crashed, I had opened it to select a tag and hit play. The phone was then locked and 10 minutes later I tried to unlock it so that I an select a different track. It immediately crashed then.

I reinstalled the app just now and sadly it crashed within 5 minutes of operation. I just tried opening the app to adjust volume and it crashed.

I cannot unfortunately identify a pattern or something that might be causing it. I can also rule out the device as I recently replaced my iPhone. The crash occurred with my previous iPhone 7 and now with the 8 as well.
I can also rule out the router as I have moved the core to a new home and a new router. Same problem unfortunately


Hi, am also getting the exact issue, just started today.

As it connects to the Roon it crashes, works fine on the desktop.



Thanks for chiming in and sharing your feedback with me, @Sanjiv_Sud! Appreciated!

Moving forward, may I very kindly ask you to please provide the following information to help aide in our evaluation of this behavior you are experiencing. Please see below.

  • Please provide a brief but accurate description of your current setup using this link as a guide.

  • Please verify the make/model of device(s) you are experiencing the reported crash on.

  • Does the Remote ever connect to your Roon core or does it just keep crashing?

  • Since noticing this behavior have you tried…

    • Reinstalling the application on the affected remote device(s)?

    • Power cycling your device (i.e Roon core, router, remotes, etc)?


Hi @Yiannis_Kouropalatis ---- Thank you for the update! Letting you know that I have sent you a PM with some further troubleshooting steps :sunglasses:


Sure. Problem sorted, I deleted the Roon app on the phone and downloaded and reinstalled it. Thanks

1 Like

Hi Eric,

I just wanted to send a quick update on this. The problem persisted for a while but it looks like it has been corrected after the latest update of the roon remote. I am happy to report I have a stable roon remote on my iphone :slight_smile:

If not done alreay I think we can close this support ticket.


1 Like

Great to hear, many thanks for touching base with me @Yiannis_Kouropalatis!

Happy listening!

1 Like