Roon Remote doesn't work [Solved]

I have trouble with my Roon setup. I installed Roon on my server (win7 pro) and it works perfectly.

I have installed Roon on a laptop (win7 pro) and set in up to be a remote. The server (core) is seen by the laptop and connects perfectly. I can browse my music ans play it.

When I shut down the Roon software and restart it (direct or later) there is big white screen with a little black screen in the middle.

I have tried everything I can think off but it won’t change a bit.

Hope that there is an solution for this problem.

Best regards Ronald

Hey Ronald, sorry to hear about this. I think we should be able to figure out the issue, but can you clarify what you mean here:

So you’re running Roon on both machines, Core and Remote respectively, and then you’re shutting it down on which machine?

If you could also post a screenshot of what you’re seeing, that would be helpful and I’m sure we can figure out what’s happening here.


Hello Mike,

Thank you for your reply. I am running Roon core on the server an remote on the laptop. When I installed roon as remote on the laptop the first boot went well. After shutting down the remote software (closing roon on laptop) and reopend it it went wrong. At first a black screen in the middle but now it stays loading.

Hope this will help

Best regards Ronald

Could be similar to #12153.

Ok thanks @thepioneer – can you confirm that when you’re seeing this, the Core app is up and responsive?

Also good call @ncpl – checking on that.

The status now is that is is like the picture. I installed adobe reader 11 and at first the remote software worked but from the second start on it is like the picture.

Best regards Ronad

SimilaR problem here. First run on the remote pc works fine. After restart of Roon on ther remote PC, I get a message that I need to run Roon in fullscreen mode, but the window is frozen, i.e. I can’t select “Fullscreen”.


The core is playing very well. Fast and smooth, also when the remote is trying to connect.

There’s a ticket for this one and I think Danny has it in hand.

Is there any suggestion of where I can search for an answer to my problem?

The answer is that “Danny is fixing it”.:grinning:

:grin::+1: then it would come to a good end.

Sorry for the trouble here – as @ncpl points out, this is a known issue, and we’re planning to deliver a fix for our next release.

For now, if you’re stuck try this unseemly workaround :blush: :

  • Use the hotkey to open preferences (Ctrl + comma on Windows)
  • On the General tab, click disconnect under Library
  • Choose your library again
  • Let us know if this works for you

Sorry again for the trouble guys. Please let us know if these steps don’t work for you, as it could be a different issue.

Thanks all!

Hello Mike,

Thank you for this reply. For me the workaround works just fine. Now I can use it as my remote till the app is ready.

Best regards Ronald

1 Like

I am having a problem understanding how to use the Roon Remote to control a Roon client. With the roon remote on my android, I can play and see all the albums on my core. However, for my mac mini which I am using as a client, I can only select and play through the mac itself. I cannot (don’t know how) use the Roon remote to control the Roon client. Am I missing something here? Thanks

Remotes can only control themselves and the core, not other remotes. In fact currently they can’t see other remotes. The functionality to do that is what is also called RoonSpeaker and no target release date has been set other than it is currently high priority

A post was split to a new topic: Android Remote Connection Issues