Roon Remote is unable to find audio device [Resolved]

Core Machine (Operating system/System info/Roon build number)

I am running Roon Core version 1.8 (build814) on a Debian linux system. It is installed on my server with i5-9400 CPU and 16GB RAM on Samsung EVO 256 SSD.

All my music files are stored in this machine, approx. 8TB of storage capacity.

My Roon remote is installed on a Mac mini running Catalina 10.15.7, version 1.8 (build814)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Roon core and Roon Bridge are connected via wired ethernet, Roon Remote via WiFi, all on the sane network.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Roon Bridge is connected to the audio device via USB, using WASAPI

Description Of Issue

As mentioned above, my Roon remote cannot find my audio device.

The audio device is plugged directly to my Roon remote Mac through USB.

The strange thing is that I can listen to YouTube fine, since the Mac is connected to the audio device. Furthermore , the device can be accessed through midi.

Any ideas as to why this is happening and how to solve it?

Hello @Fragoulis_Sideris

Thank you for reaching out to us with your question. We’d be happy to help with this.

Can you please clarify here whether you’re having issues with a device connected to a Bridge or directly to your Roon Remote?

Once we have this information we can jump in and help you begin troubleshooting! We liked to get this resolved as quickly as possible so you can get back to enjoying your favorite music in Roon!

Thank you for your answer.

I am having issues with a device connected directly to my Roon Remote

The architecture (nomenclature ) looks funny, By Roon Remote do you ,mean an end point connected to audio kit

Core to Bridge to USB DAC to amp etc

The remote is normally a hand held device, ipad, iPhone etc not connected directly to an audio devices

Where is the Roon Bridge software installed where on the Mac mini ?

In Settings Audio is the Device Enabled ?

My system setup is the following

Roon bridge is installed on a small windows 10 of at the living room

Roon core is installed on my main server located at my office. This is where my main music library resides.

On My Mac mini is installed a version of roon which is connected to my server through lab cable and with my audio device through USB on the other side.

Audio device is enabled, since I can listen to YouTube without problems.

If I uninstalled everything and install anew, wouldn’t all the problems be solved?? :thinking:

Another strange thing that I noticed is that the output of the command:
“systemctl status roon” returns the result “Unit roon.service could not be found.”

How can this be possible?

I am using the following commands for installing Roon:

  • install curl
    sudo apt-get install curl
  • install bzip2 to uncompress the file
    sudo apt-get install bzip2

sudo apt-get install ffmpeg
sudo apt-get install cifs-utils

$ curl -O
$ chmod +x

end result of all the above is that Roon is running as a service now!
$ sudo ./

I still think your system is confused. Maybe read the Knowledge Base to better understand the Roon Architecture

Roon Bridge is designed to act a literally a bridge between the network and the DAC ie as a streamer, it should be run headless without a GUI, so you cannot use it to CONTROL Roon , simply to transfer data from the network.

Essentially as I see your system …

Core Installed on Office Server I get that (that can be either Roon Server or full Roon GUI)

The Mac Mini is actually acting as your “Roon Bridge” by running a full version of Roon by the look of things (so here you COULD install Roon Bridge)

The system should be (as far as I see it)

Roon Core (Either server or Full GUI app) on office server
LAN to
Mac Mini (Running Full Roon GUI App or Roon Bridge if “headless”)
Your DAC / Audio set up

The Laptop I assume you are using as a “laptop remote” (Where most people are using a mobile device , iPhone, iPad etc) just to control what is played NOT connected to any audio equipment . So it should have a “Full GUI Roon app” installed NOT Roon Bridge. That way you can connect to your
Unless you install Roon Bridge on your Mac Mini there is no need to Roon Bridge on this system. Roon Bridge is designed for use in a headless operation ie no GUI.

What you should see in Roon CORE >Settings>Audio is the Mac Mini , that needs to be enabled.

You should also see the Laptop but since its not connected to anything (audio) doesn’t need to be enabled .

If you enable it then you can play your Core Library through the laptop speakers, those speakers will need to be enabled on the Laptop Copy of Roon not the Core

Have I got it clear now ?

Hi @Fragoulis_Sideris,

Just to confirm, the DAC is connected via USB to the Mac which is a remote in your setup.

  • Do you see any other audio devices from the Mac showing up in Settings > Audio? Can you share a screenshot of what you do see here?
  • If you connect this DAC directly to the Core via USB does it show up?

I presume he’s fixed it ???

I am sorry for delaying replying but I was away for the weekend.

Attached you can find requested screenshot. As you can see, in MIDI settings the Mac can see the audio device connected via USB. Under Roon, nothing is visible.

I cannot connect the audio device to the Core, as it is at a different room and there is no available power outlet

Another screenshot might be helpful

Can you try this, @Fragoulis_Sideris:

  • Exit out of Roon/Roon Server
  • Navigate to your Roon Database Location - Database\Registry\Core
  • Locate your tidal_account file and delete it
  • Try to start Roon again

I cannot find the file you mention. Below screenshot shows what files and folders are located under /Database/registry/Core.

What should I delete?


I tried to uninstall Roon and install it back, but the same problem remains. Are there any remaining folders during uninstalling?

Thanks for giving that a try, @Fragoulis_Sideris. Can you please use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service)?


You can find the requested logs in the link below:

1 Like

Hi @Fragoulis_Sideris,

Can you take a look at the article linked below and follow the steps outlined there? Thanks!

that did the trick!

As I understand, this will create a new database.

However, how will I delete the old database, since my disk drive is limited

Hello @Fragoulis_Sideris

We’re happy to hear that the troubleshooting steps in the article that Dylan provided were successful in solving your issue. Once the previous database has been renamed and set aside Roon is no longer utilizing it and it can be safely deleted.

If you have any issues in the future please don’t hesitate to reach out to us here for help! :+1: