Roon remote memory usage...250mb >> 1.3gb!

I normally do not shut down my Roon remote app on my laptop. I noticed over that past few days performance has been getting more and more sluggish. This morning I looked at the memory usage and it was at 1.3gb!. After I shut down Roon remote, memory usage as 250mb. After about 30 mins its up to 800mb. On a related note, as I mentioned in another post, Roonserver memory also increases, though more gradually. Roonappliance.exe now consumes 1.2gb of memory.

Can memory usage be managed better?

I noticed the same thing, yesterday I turned my roon core PC on, modest library 1500 albums. Task manager reported roon using just over 500mb of ram but it was slowly increasing, 8 hours later while playing music continuously task manager reported roon was using almost 1.2gb of ram. My win 10 machine has 8gb of ram. What I have done to manage this since I only have roon core on this machine is simply close roon and then re-open when I want to listen next. I think there is a setting in somewhere in roon settings to re-set the cache I never tried that as I was worried it would mess up my history since last back up. I wonder if that would reset ram and leave your history in tact?

I think the memory setting you are looking for is in Settings–>Setup–>Memory.

RAM usage should never affect what is stored in your database, as these are independent. You may or may not notice a difference in performance scrolling through images.

As an aside, since I run RoonServer on a headless machine running little else, I wish I could increase the memory usage beyond the current maximum since Roon “only” uses 25% of the RAM resources (~1.3GB of 6GB).

woke up this morning to Roon and my laptop performing sluggishly. Looked in Task Manager and Roon is consuming 1.3GB of RAM! Restarted and memory is at 250MB.

@support this memory leak seems to a real issue. Any ideas?

@tboooe – just to confirm, this is a remote right, not Core? If so, this is a different issue from what @Quadman is describing.

Can you tell us what you have the artwork memory setting at? Does lowering it help?

Lastly, would you mind dropping a screenshot of where you’re seeing this memory usage, in addition to the basics of your setup (as described here)? Assuming I’m understanding this correctly, the details of your remote machine should suffice.

With those details, we can look into this further. Thanks!

Mike, I filed a bug on the iPad losing images and being ok after app restart. Sounds like a memory leak to me, or at least some sort of resource leak. But I don’t have much instrumentation on the Ipad to tell me what’s going on.

@mike for me this happens on my remote.

My artwork setting is 512mb. I will try a lower setting.

I am seeing the memory usage in normal Windows Task Manager.

I have Roonserver running in a headless PC (i7-3770s, 8GB RAM Server 2012 R2). This PC communicates with my network via a wireless AC bridge (Dlink DAP 1650). I have an AC wireless router upstairs (Netgear Nighthawk R7000). My music network is on the 5ghz channel and is separate from my regular network on the 2.4ghz channel. I have no issues streaming 1080p video or DSD256 files on my network. The only apps on this PC is HQP and Roonserver. The CPU usage on this PC is usually 2-10% when listening to Tidal or PCM flac files.

My remotes are an i3 laptop and Android tablet also communicating via wifi on my network.

After reducing the memory setting to minimum, Roon remote on my laptop is up to 1.1GB this morning.

I have kept my PC running since this thread and my core machine with 128mb for artwork has kept near 1.2 GB ram, at the end of last night (6 1/2 hours listening) it was 1.4 gb, with total ram usage of 40% (whole system). My remote a surface pro knock off with win 10 I use 96 mb for art work and uses a consistent 500 mb of ram and overall ram usage on that is apprx 50%.

I just checked my Remote on my NUC Skull Canyon with 32Gb on memory, 11.3Gb used! Restarted Remote, using 294mb now, and climbing slowly. Wow!!! Set artwork to 64mb , it was set to 512, see what happens.

Just a FYI, checked my remote, Lenovo Yoga Core i7 w/ 16GB RAM and memory utilization is 1.4GB, Artwork set to 256MB.

RoonServer running a QNAP TVS-882 Corei5 w/ 32GB is consuming 1.2GB of RAM.


11.3 GB is pretty much but for a database app that does a lot of caching anything between 1 and 2 GB is absolutely normal behaviour. Your OS can claim it back instantly if it ever needs it. that’s how memory management works. Be glad your ram is being used, why else did you put 16 or even 32 GB of ram in your system? to sit there idling?

For VMs! and other apps like LMS, Plex, and MySQL!!! So yea it just idles, NOT!

Hit a new record today…1.6GB…Roon remote started getting very sluggish.

I just had to restart Roon remote running on my laptop. It was showing 1GB of memory usage!

I reported on this issue here:

8 posts were merged into an existing topic: High memory usage (memory leak?)

Holy cow! This sounds a lot like some of the issues I’m experiencing with my LampizatOr DSD Komputer music server prototype review sample. It worked fine with the original Daphile software and the subsequent Roon with HQ Player upgrade, but with Roon 1.3, it works, but during a listening session, has disconnection issues, becomes more sluggish, slows down, and – at times – starts skipping and eventually stops playing. This forces me to shut it down and start it up again.

I am wondering if this has to do with hardware issues in the prototype not being robust enough to support Roon 1.3. I am waiting to hear back from the principals at LampizatOr. Any thoughts?

I think there is a memory leak in Roon server. When I do a skip next track, or previous track, the memory use increases with about 12Mbyte. This is easy to reproduce I think. Did some skipping back and forth, I’m now at 1 Gig memory use.

I have that behavior when I have a convolution filter applied, but if I remove the convolution filter the problem disappears. I have sent it to Roon devs and got the reply they had solved it, so next version should fix the problem.

Indeed, it’s in the Convolution engine.